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Windows 1.0
Microsoft first began development of the Interface Manager (subsequently renamed Microsoft 
Windows) in September 1981.    Although the first prototypes used Multiplan and Word-like menus at 
the bottom of the screen, the interface was changed in 1982 to use pull-down menus and dialogs, as 
used on the Xerox Star.    

Microsoft finally announced Windows in November 1983, with pressure from just-released VisiOn and
impending TopView.    This was after the release of the Apple Lisa (but prior to the Macintosh), and 
before Digital Research announced GEM, another competing graphical environment.    Windows 
promised an easy-to-use graphical interface, device-independent graphics and multitasking support.   
The development was delayed several times, however, and the first version hit the store shelves 
(after 55 programmer-years of development!) in November 1985.    The selection of applications was 
sparse, however, and Windows sales were modest,

The following were the major features of Windows 1.0:
· Graphical user interface with drop-down menus, tiled windows and mouse support
· Device-independent screen and printer graphics
· Co-operative multitasking of Windows applications



Windows 2.0
Windows 2.0, introduced in the fall of 1987, provided significant useability improvements to Windows. 
With the addition of icons and overlapping windows, Windows became a viable environment for 
development of major applications (such as Excel, Word for Windows, Corel Draw!, Ami, PageMaker 
and Micrografx Designer), and the sales were spurred by the runtime (Single Application 
Environment) versions supplied by the independent software vendors.    When Windows/386 (see 
next section) was released, Microsoft renamed Windows to Windows/286 for consistency.

The following are the major changes from earlier versions of Windows:
· Overlapping windows
· PIF files for DOS applications



Windows/386
In late 1987 Microsoft released Windows/386.    While it was functionally equivalent to its sibling, 
Windows/286, in running Windows applications, it provided the capability to run multiple DOS 
applications simultaneously in the extended memory.

The following are the major changes from earlier versions of Windows:
· Multiple DOS virtual machines with pre-emptive multitasking



Windows 3.0
Microsoft Windows 3.0, released in May, 1990, was a complete overhaul of the Windows 
environment.    With the capability to address memory beyond 640K and a much more powerful user 
interface, independent software vendors started developing Windows applications with vigour.    The 
powerful new applications helped Microsoft sell more than 10 million copies of Windows, making it the
best-selling graphical user interface in the history of computing.

The following are the major changes from earlier versions of Windows:
· Standard (286) mode, with large memory support
· 386 Enhanced mode, with large memory and multiple pre-emptive DOS session support
· No runtime versions available
· Program Manager and File Manager added
· Network support
· Support for more than 16 colors
· API support for combo boxes, hierarchical menus and private .ini files



Windows 3.1 92-09-21
Microsoft Windows 3.1, released in April, 1992 provides significant improvements to Windows 3.0.    In
its first two months on the market, it sold over 3 million copies, including upgrades from Windows 3.0.

The following are the major changes from Windows 3.0:
· No Real (8086) mode support
· TrueType scalable font support
· Multimedia capability
· Object Linking and Embedding (OLE)
· Application reboot capability
· "Mouse Trails" for easier mouse use with LCD display devices
· Better inter-application protection and better error diagnostics
· API multimedia and networking support
· Source-level API compatability with Windows NT



Windows for Workgroups 3.1 92-11-09
The Windows for Workgroup package is the first integrated Windows and networking package offered
by Microsoft.    It provides peer-to-peer file and printer sharing capabilities (on a level comparable to 
LANtastic or Netware Lite) highly integrated into the Windows environment.    The simple-to-use-and-
install networking allows the user to specify which files on the user's machine should be made 
accessible to others.    The files can then be accessed from other machines running either Windows 
or DOS.    

Windows for Workgroups also includes two additional applications: Microsoft Mail, a network mail 
package, and Schedule+, a workgroup scheduler.



Windows NT 3.1
Microsoft Windows NT, scheduled for release at the end of 1992, is Microsoft's platform of choice for 
high-end systems.    It is intended for use in network servers, workstations and software development 
machines; it will not replace Windows for DOS.    While Windows NT's user interface is very similar to 
that of Windows 3.1, it is based on an entirely new operating system kernel.

The following are the major changes from Windows 3.1:
· Based on a new microkernel design
· Portable architecture for Intel x86, MIPS R4000 and DEC Alpha processors
· 32-bit addressing for access to up to 4 GB of memory
· Fully protected applications with virtualized hardware access
· Installable APIs for Win32, Win16, MS-DOS, POSIX and OS/2
· Installable file systems, including FAT, HPFS and NTFS
· Built-in networking (LAN Manager and TCP/IP) with remote procedure calls (RPCs)
· Symmetric multiprocessor support
· Security designed in from start, to be initially C2 certified, with a B-level kernel design
· API support for unsynchronized message queues, advanced interprocess communication, 

registration databases, Bezier curves and graphics transformations.

Although Windows NT has not yet been released, the following is generally accepted as the minimum
platform for use with the retail release of Windows NT:
· 33 MHz 386 processor
· 8 MB memory
· 100 MB hard disk
· VGA graphics

As of July 1992, Windows NT is available as a pre-release SDK (Software Development Kit) from 
Microsoft at the cost of $69 (or $399 for the pre-release SDK plus full printed documentation).    This 
release is supplied on CD-ROM only, and contains the Windows NT operating system as well as all 
the necessary 32-bit development tools (including a 32-bit C++ compiler and all documentation online
on the CD-ROM).    The purchasers of this SDK will also receive free updates to Windows NT up to 
and including final release.

The pre-release Windows NT SDK requires 12 MB of RAM and is not suitable for evaluating the 
Windows NT environment.    It is intended strictly for software development!    Contact your national 
Microsoft subsidiary (or Microsoft itself in Redmond, WA) for ordering information.



Win32s for Windows 3.1 92-11-09
Win32s is a set of libraries for Windows 3.1, which enable users to run most Windows NT 32-bit 
applications on Windows 3.1, without the extensive hardware requirements of Windows NT.    The 
Win32s interface will likely replace the older Windows-32 interface used by current 32-bit Windows 
applications such as Mathematica.

The Win32s development tools are currently in beta release, but Microsoft has not announced 
minimum system requirements for using Win32s applications.



Windows for Pen Computing 3.1
Microsoft developed Windows for Pen Computing for use on pen-based systems.    In most aspects, it
is basically equivalent to Windows 3.1 with extensions for pen support.    These extensions include the
useof a pen as a pointing device as well as handwriting recognition and conversion.    Pen Windows 
first shipped in April, 1992.



Multimedia Windows
The term Multimedia Windows describes a package with Windows 3.0 and the Multimedia 
Extensions.    These extensions are included in Windows 3.1, and thus Multimedia Windows is no 
longer sold as a separate product.



Modular Windows
Modular Windows is the operating system for Tandy Corp.'s Video Information System (VIS) 
multimedia player.



WinOS2
WinOS2 is the Windows component of IBM's OS/2 2.0.    It is based partially on Windows 3.0 and 
partially on 3.1.    While it runs a majority of the commercial Windows applications, it is not covered by 
this document.
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Usenet
If you received this FAQ from somewhere other than Usenet or Internet, you may not be familiar with 
Usenet.    Basically, Usenet is a loose collection of over 100,000 computers which exchange mail and 
news.    The network is unstructured and highly distributed; most communication is either by TCP/IP 
over high-speed connections, or UUCP over public telephone lines.    Internet is a (almost proper) 
subset of Usenet, consisting of somewhere    between 50,000 and 100,000 computers connected by 
high-speed TCP/IP network connections. 

Usenet news is a software system where a person can post an article to a selected newsgroup, and 
have every other news reader be able to read it.    There are over 1000 newsgroups (including the alt 
groups), and daily volume of news is approaching 40 MB.

While most Usenet systems are Unix-based, it is not a requirement.    If you have an Internet or UUCP
connection, ask your system administrator whether you have Usenet news available.    Some of the 
most common newsreading software packages are readnews, rn, trn, nn and notes.



Usenet Windows newsgroups
There are a total of eight Usenet newsgroups dealing with Microsoft Windows: 

· comp.os.ms-windows.advocacy
This group is intended for adversarial discussions, arguments and comparisons to other 
computers and operating systems. 

· comp.os.ms-windows.announce
This is a low-volume moderated group with only Windows-related announcements and with no 
discussion.      Moderated by Todd Derr (infidel@pitt.edu).

· comp.os.ms-windows.apps
This group contains discussions, questions, and comments about the selection and use of 
Windows applications.

· comp.os.ms-windows.setup
This group is meant for questions and discussions about Windows setup process, driver 
availability and selection, and hardware compatability and selection. 

· comp.os.ms-windows.misc
All other discussions about Windows should be in this group.

· comp.os.ms-windows.programmer.tools
This group is intended for discussions about the selection and use of    tools for Windows software
development. 

· comp.os.ms-windows.programmer.win32
All discussions about the Win32 applications programming interface (used in Windows NT and 
Win32s) and the Windows NT SDK belong in this group.. 

· comp.os.ms-windows.programmer.misc
This group is for all other discussions about Windows software development.

The following groups have been replaced by those shown above: 
· comp.windows.ms

This group was for discussions about Microsoft Windows.
· comp.windows.ms.programmer

This group was for discussions about programming for Microsoft Windows.

The following groups may also be of interest: 
· comp.os.msdos.programmer

This groups contains general MS-DOS programming questions.    Some, especially those 
concerning compiler selection, may be of interest to Windows programmers.

· bit.listserv.win3-l
This group is a two-way gateway of the BITNET WIN3-L mailing list.

The following groups are not for Microsoft Windows!
· comp.windows.misc

This group is for miscellaneous discussions about windowing systems in general.
· comp.windows.news

This group is for dicussions about the Sun Microsystems NeWS windowing system.

In general, these newsgroups are only available to computers connected to Usenet or Internet; they 
are not gatewayed into BITNET, CompuServe, Prodigy or other services. Some FidoNet BBS 
systems, however, do carry selected Usenet newsgroups.



Alternatives to Usenet
If you are unable to find a connection to the Internet (that procedure can not be easily defined, as the 
Internet does not have any sort of a formal structure), there are several alternatives available for 
finding more information about Windows, and for locating Windows software and drivers.

BITNET users (as well as any other with an electronic mail connection to Internet) can subscribe to 
WIN3-L (win3-l@uicvm.bitnet), a mailing list dedicated to Windows discussions.    This mailing list is 
similar in content to the comp.os.ms-windows.misc newsgroup; no programmer mailing list exists 
on BITNET.

If you live in North AMerica (or in one of selected Western European countries), you can subscribe to 
CompuServe, a commercial service.    CompuServe has extensive Windows-oriented discussions and
a fairly good selection of free software.    Although the level of discussion is often less technical, it is 
much more structured than the Internet.    CompuServe also has numerous vendor-supported forums, 
including ones organized by Microsoft for Windows and Windows NT.

Many FidoNet-based BBS systems also carry the Internet Windows newsgroups.    Consult a local 
BBS listing to find your nearest FidoNet BBS.



Freeware and shareware by ftp
While CompuServe (which has a lot of software) and your local BBS may have large selections, the 
Internet provides an immense resource for all PC users.    The key program to access this software is 
called ftp (File Transfer Protocol), and it's useable from most Internet system, but is not usable 
through UUCP links.    

If you do have ftp available to you, follow the example below to connect to ftp.cica.indiana.edu (do not
type in the // comments):

$ ftp ftp.cica.indiana.edu // make connection
Connected to ... // cica responds
Userid (user@cica): ftp // enter "ftp" as userid
Password: real_userid@site // enter your own userid
ftp> tenex // for binary transfers
ftp> cd /pub/pc/win3 // where the goodies are
ftp> ls -l // list the directory
ftp> get ls-ltR // get the current index
ftp> quit // we're done!
$ _

Of course, you can get multiple files at a time    read the ftp manual page for more information.    

Remember that shareware is not free: register the software you use to encourage the development 
of more low-cost software.



Popular Internet ftp sites 92-10-07
The following ftp sites provide significant amounts of software of interest to Windows users: 
· ftp.cica.indiana.edu (129.79.20.84)

Directory /pub/pc/win3  contains one of the largest selections of Windows software and device 
drivers anywhere.    Mirrored by wuarchive.    Please do not access ftp.cica.indiana.edu between 
8am and 6pm EST to prevent overloading the system.

· simtel10.army.mil (26.2.0.74)
Directories /msdos1, /msdos2 and /msdos3  contains a very large selection of MS-DOS (and 
some Windows) software.    Mirrored by wuarchive.

· wuarchive.wustl.edu (128.242.135.4)
Directory /mirrors/win3 contains a copy of the cica Windows archives, and directory 
/mirrors/msdos contains a copy of the simtel10 MS-DOS archive.

· ftp.uu.net (137.39.1.9)
Directory /vendors/microsoft contains a lot of the Microsoft developer support materials available 
on CompuServe, including tech notes, sample sources and WinHelp documentation for SDKs. 

· garbo.uwasa.fi (128.214.12.3)
Directories /win3 and /win31 contain a majority of the cica Windows archives, and a fair amount f 
non-cica material.    Note that garbo.uwasa.fi is located in Finland, and North American users 
should avoid congesting transatlantic Internet links by ftping from this site.    Mirrored by 
wuarchive.

If your ftp program complains about an unknown site, you can substitute the numeric Internet 
address (shown after each site name above) for the name in the ftp command.



Using archie 92-09-21
If you know the program you're looking for, but don't know where to find it, you might try using a utility 
called archie.    This program allows you to search for a filename in all the available ftp sites.

There are numerous archie servers available; to use one of them, telnet to the system, and sign on as
archie.    Follow instructions to search for a file.    The following lists some of the know archie servers 
currently available for use; pick one in your geographical area:

· archie.rutgers.edu United States (Northeast)
· archie.sura.net United States (Southeast)
· archie.unl.edu United States (West)

· archie.mcgill.ca Canada
· archie.au Australia and New Zealand
· archie.funet.fi Europe
· archie.doc.ic.ac.uk United Kingdom



Ftp by email
There are several sites that will perform general FTP retrievals for you in response to a similar mail 
query, although it appears that the info-server@cs.net server is permanently out of order.    

In general, please be considerate, and don't over-use these services.    If people start using them to 
retrieve megabytes and megabytes of GIF or WAV files, they will probably disappear.    Also, keep in 
mind that your system may be linked to the net using a long-distance UUCP connection, and your 
sysadmin may not be happy about large mail files using up modem time and filling overloaded spool 
directories.

· bitftp@pucc.bitnet
For information on this one (available only to BITNET sites) send it the message:

help

· ftpmail@decwrl.dec.com
For information on this server, available to all Internet sites, send it a mail message with a body 
containing simply:

help

· mailserv@garbo.uwasa.fi
One final choice is to use the garbo.uwasa.fi server, which lets you access the garbo.uwasa.fi 
archive (which contains most of the cica files).    For instructions, send it a mail message with 
"Subject: garbo-request" and a single line of text "send help" to 

send help
Please do not use this service if you are located in North America!



More about Internet and Usenet 92-09-25
To learn more about Internet and Usenet, I strongly recommend you purchase or borrow a copy of Ed 
Krol's The Whole Internet User's Guide and Catalog (ISBN 1-56592-025-2, $24.95), which covers 
email, news, ftp, archie and much more.    This 400-page handbook is a thorough guide to getting 
around on the Net, clear enough for neophytes but with new information even for true Internet 
veterans.    

To purchase The Whole Internet User's Guide and Catalog, check your local bookstore or contact the 
publisher, O'Reilly and Associates at 1-800-998-9938 (103 Morris St., Sebastopol, CA 95472).



FTP archives on CD-ROM 92-09-21
Walnut Creek offers copies of the cica, wuarchive and simtel  FTP archives on CD-ROM, at prices 
ranging from $25 to $50, with annual subscriptions available.    Call (800) 786-9907 or (510) 947-5996
for more information.
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Minimum Windows 3.1 configurations
The minimum    system configurations to run Windows 3.1 are as follows:
· Standard Mode

286 processor, 640KB base memory, 256KB extended memory, EGA graphics
· 386 Enhanced Mode

386 processor, 640KB base memory, 1MB extended memory, EGA graphics

The following are recommended    minimum configurations (based on the experiences of many net 
Windows users) for good performance.
· Standard Mode

286/12 processor, 2MB total memory, VGA graphics, mouse
· 386 Enhanced Mode

386SX/16 processor, 4MB total memory, VGA graphics, mouse



Minimum Windows 3.0 configurations
The minimum system configurations to run Windows 3.0 are as follows:
· Real Mode

8088 processor, 640KB base memory, CGA/Hercules graphics
· Standard Mode

286 processor, 640KB base memory, 256KB extended memory, CGA/Hercules graphics
· 386 Enhanced Mode

386 processor, 640KB base memory, 1MB extended memory, CGA/Hercules graphics

The following are recommended    minimum configurations (based on the experiences of many net 
Windows users) for good performance.    (Real Mode is not configurable for good performance, and 
many applications will not run in it due to a lack of memory.)
· Standard Mode

286/12 processor, 2MB total memory, VGA graphics, mouse
· 386 Enhanced Mode

386SX/16 processor, 4MB total memory, VGA graphics, mouse



Minimum Windows NT pre-release configuration
The minimum    recommended    system configurations to run the Windows NT pre-release Software 
Development Kit is as follows:

· 33 MHz 386 processor
· 12 MB memory
· 100 MB hard disk
· VGA graphics



Standard mode vs. 386 Enhanced mode
If you own a 386- or 486-based system, you have the choice of running in either Standard or 
Enhanced mode.    The following lists the advantages of each:

Standard mode
· Speed.    Many aspects of Windows run substantially faster in Standard mode than in 386 

Enhanced mode.

386 Enhanced mode
· Virtual memory capability.
· Multiple DOS sessions are pre-emptively multitasked.
· DOS sessions may be run in a window.
· Able to run 386-specific applications such as Mathematica, FrameMaker and wdeb386.



System BIOS compatability 92-09-21
A number of different computers have BIOS incompatabilities with Windows 3.1.    The following list 
contains BIOSes with such problems.    Contact you manufacturer for an update if you have one of 
these systems.

Manufacturer Version Problem

ALR MPS Incompatible with Seagate IDE disks
AMI 1987 Floppy access causes reboot
AMI 1989 Intermittent crashes
AMI 1991 Serial port problems
AST Premium/286 Crashes, keyboard lockups and network errors
Award BIOS - 3.04 Floppy read errors before version 3.05 
DTK BIOS - 34 No IDE drive support
DTK BIOS 36 Setup utilities must be disabled
Peak BIOS 1.10 1.30 or newer is required
Phoenix BIOS - 1987 1988 or newer is required
Quadtel BIOS - 3.04 3.05 or newer is required
Tandon All Old BIOSes cause keyboard failures
Toshiba T3100/20 BIOS 4.2 is required
Toshiba T3100e BIOS 1.7 is required
Wyse All Setup detects 101 keyboard as 84
Zenith 286 Keyboard problems
Zenith 386/16 BIOS 2.6E or newer is required
Zenith TurboSport BIOS 2.4D or newer is required

The BIOS name and version number (or date) are usually displayed when the system boots.    As an 
alternative, you can use msd.exe, a DOS-based diagnostic utility included with Windows 3.1, to 
determine the BIOS your system is using.    Also, there are several diagnostic utilities available in 
wuarchive's /mirrors/msdos/info directory: sysch233, sysid602 and ifp1p155.
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Identifying Your Video Card 92-09-28
The first step in finding the correct Windows drivers for your video card is to determine the type of 
card you have.    First, you may have a "brand-name" card; if so, your box and/or documentation will 
ientify the type of card.    Second, you can look at the BIOS message (if any) displayed when you boot
your system.    Third, you can open up your system, and look for identification on the card itself    
usually either printed on the card itself or on some of the integrated circuits.    

As an alternative, you can use msd.exe, a DOS-based diagnostic utility included with Windows 3.1, 
to determine the manufacturer and type of video card in your system.    Also, two utilities available 
from wuarchive, atmem10 and vgautils (in directory /mirrors/msdos/vga) may help you identify your 
video card.

See the following section on locating a video card driver for a listing of possible names to look for.



Locating a driver
Once you have identified your card, you are ready to begin searching for the right driver.    First, check
whether Windows includes the driver you are searching for (Windows 3.1 includes generic VGA 
(640x480x16) and SuperVGA (800x600x16) drivers, as well as numerous specific drivers).    Second, 
look at the diskettes you received in the video card package.    These may contain the appropriate 
driver, saving you from a further search.    

If neither Windows nor the diskettes have the drivers, or they are out of date, you may wish to check 
ftp.cica.indiana.edu for the latest one.    If there are none at cica, you can try one of the following:

· Contact your dealer
· Call the video card manufacturer
· Download the latest driver from the manufacturer's BBS
· Download the latest driver from the Microsoft BBS (206-936-6735) 

Note that Windows 3.1 drivers are normally dated after the release date of Windows 3.1 itself (April 6,
1992).



Video card manufacturers
The following is a partial list of video display hardware vendors who support using Windows with their 
products.    CAUTION:    The numbers listed may not, by the time you read this, be up to date!

Ahead Systems 510-623-0961
Appian Technology 206-649-5363
ATI Technologies 416-756-4591
Boca Research 407-241-1601
Diamond Computer 408-730-1100
Everex Systems 510-226-9694
Focus Information 510-657-9451
Headland Technology Video Seven 510-656-0503
Matrox Electronic 514-685-6008
Micro-Labs 312-648-6008
Micron Technology 208-368-2130
National Design 512-343-5054
NEC NEC 512-832-1962
Nth Graphics Nth Graphics 512-832-1962
Number Nine Computer Number Nine 617-862-7502
Orchid Technology Orchid 510-683-0327
Panacea WinSpeed 603-432-5193
Sigma Designs Sigma 510-770-0111
STB Systems STB 214-437-9615
Tecmar Tecmar 216-349-0853
Trident Microsystems Trident 415-691-1016
ViewSonic ViewSonic 213-944-2195

The following vendors do not provide BBS access, but do make updates available on CompuServe, in
the forum indicated.

Tseng Laboratories ET3000, ET4000 WINADV



Using 256 (or more) colors in Windows
In order to use more than 16 colors in Windows, your display card and its driver must first support 256
colors.    Second, your application must know about 256 colors in order to take advantage of this 
feature, as this requires palette switching and some additional programming.    Many applications 
currently on the market only support 16 colors.    

In order to get 256 colors, your video card will need at least 320K (for 640x480), 512K (for 800x600) 
or 768K (for 1024x768) of RAM.    For most video cards, 256-color drivers are also much slower than 
16-color drivers.    Some video cards support 15-bit (32,768 colors) or 24-bit (16,777,216 colors) 
video; these can also be used in Windows given the appropriate display driver and sufficient video 
memory.



Panacea Winspeed
One alternative to the specific manufacturer-supplied drivers is to use Panacea's Winspeed drivers.    
These drivers often provide a substantial speed improvement over vendor-supplied drivers, although 
some vendors have highly optimized drivers which can meet or exceed Winspeed's performance.



CGA drivers 92-09-19
Windows 3.1 does not include CGA drivers, as the recommended minimum for running Windows 3.1 
is EGA.    If you need to run Windows on a CGA system, you can download the CGA drivers from the 
Microsoft BBS (206-936-6735).



Printer drivers
The following is a partial list of printer manufacturers who support using Windows with their products.  
CAUTION:    The numbers listed may not, by the time you read this, be up to date!

Canon Canon 516-488-6528
Lexmark IBM laser printers 606-232-5653
NEC NEC 508-635-6328
Okidata Okidata 800-654-3282
Panasonic Panasonic, Roland 201-863-7487

The following vendors do not provide BBS access, but do make updates available on CompuServe, in
the forum indicated.

DEC DEC DECPCI
Varityper Varityper Desktop Publishing

Selecting a PostScript printer driver 92-10-31
Eliminating the Ctrl-D in PostScript output 92-10-31



Selecting a PostScript printer driver 92-10-31
If your PostScript printer model is not listed in the available printers listing, you should not choose the 
generic PostScript printer.    Microsoft advises that "if you select PostScript Printer, you may encounter
problems when printing".    Instead, you may wish to try Apple LaserWriter as your first possibility.



Eliminating the Ctrl-D in PostScript output 92-10-31
To prevent Windows from placing a Ctrl-D (printer reset) at the beginning of your PostScript output 
files, specify 

CtrlD=0
in the [ModelName,Port] section of your win.ini file.

Note that this method does not appear to work with the generic PostScript Printer driver.



Math coprocessors and WIN87EM.DLL
Windows 3.x itself does not take advantage of a math coprocessor.    Windows applications, on the 
other hand, may or may not, depending on the application: for example, Excel will, while Word for 
Windows won't.    In general, an 80x87 chip gives the greates speedup for trigonometric/log type of 
calculations, and does not significantly improve graphics speed in most cases.

The WIN87EM.DLL is a dynamic link library which provides floating-point emulation for Windows 
applications.    Any application which is capable of using an 80x87 will need this library on a machine 
without an 80x87.
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AdLib cards and .wav files 92-09-14
The standard AdLib driver supplied with Windows 3.1 is a MIDI-only driver and is not capable of 
playing .wav files.    You can add this capability, however, by installing the driver contained in 
adlibw.zip, available at ftp.cica.indiana.edu  and other sites.



SoundBlaster Pro and Windows 3.1
One of the most common symptoms of SoundBlaster Pro problems in Windows 3.1 is a complete 
hang of the system on exit from Windows.    You need to use the SoundBlaster Pro drivers, not the 
SoundBlaster 1.5 drivers included with Windows 3.1.    The drivers shipped with SB Pro are currently 
out of date, as are those on Microsoft's BBS and on CompuServe (this may, however, have changed 
by the time you read this).    In any case, ftp.cica.indiana.edu has the set of updated drivers available 
as sounds/sbpw31.zip.    You can also get them from Creative Labs' BBS at (408) 428-6660.



Using the PC's built-in speaker 92-09-14
Windows 3.1 does not contain a driver for playing sounds over the PC's built-in speaker, as the 
speaker is not quite standardized and not all machines would work as intended.    If you would like to 
try, however, you should get a copy of the speaker driver, contained in the self-extracting archive 
speaker.exe, available at Microsoft's BBS, ftp.cica.indiana.edu  and other sites.



System Resources
Free system resources are things such as window handles and global memory block handles (handle 
is a Windows programming term, but it is basically an identifier for a window or any other global item.  
Each window (dialog, icon, memory block, or whatever) requires a handle.

Windows 3.0 has a limit of 64K of resources (32,768 handles), and Windows 3.1 has a limit of 128K 
of resources (65,536 handles).    Windows NT does not have a global resource limit.

You can't increase system resources by just adding more memory; the only real solution is to close 
some applications if you are running low.    Windows 3.0 Program Manager was a resource hog, but 
the 3.1 version is much better.    

Some poorly-written applications will also not release all the resources they have grabbed when they 
exit.    You can check for this by checking the Free System Resources figure, starting up the 
application, working in it for some time, and then exiting.    If the Free System Resources figure is not 
the same as before you started, your application is not properly freeing its resources and it's time for 
you to call the vendor and complain!



Communications
Networks 92-09-15
Using COM3 and COM4 92-11-09
Using a high-performance 16550 serial port 92-09-15
DOS boxes and 16550 serial ports 92-09-28
SmartDrive and 16550 high-speed transfers 92-09-27



Networks 92-09-15
The following networks have either been tested by Microsoft, or reported by Usenet users to be 
functional with Windows 3.x:

Network                          earliest version
3Com 3 Plus 1.0
3Com 3+Open 1.0
Banyan Vines 4.0
BW NFS ?.?
DEC PathWorks 4.0
IBM PC LAN 1.1 [except server]
LAN Manager 1.0
LAN Server 1.0
LANtastic 4.0
Novell Netware 2.15 [shell & utilities must be version 3.01]
Sun PC-NFS 3.5 [must use interrupt 3 instead of 5]
Wollongong NFS 2.0 [includes Windows telnet application]



Using COM3 and COM4 92-11-09
This is a generally a problem only in 386 enhanced mode.    To use these ports, you will need to tell 
Windows where they are located.

For Windows 3.1, you should run the MSD.EXE utility while outside Windows. This utility will allow 
you to determine your COM port configuration. After running MSD, use the Control Panel's Ports 
utility to tell Windows how your ports are configured.

For Windows 3.0, the instructions for doing this can be found in the Windows readme file sysini2.txt, 
which should be located in your Windows directory.    In summary, what you need to do is tell 
Windows what memory addresses and interrupts (IRQs) your COM3 and COM4 ports use.    This 
should work, but is not guaranteed to: COM3 and Com4 are not standardized, and this is one of the 
most difficult things to get working with Windows.    If possible, move your devices to COM1 or COM2. 

If the port still does not work after specifying the correct IRQ and memory address for the port, there 
is another possibile solution: Assuming the ports work OK from plain DOS, try setting up COM3.OS2 
(or COM4.OS2) instead of the usual COM3 or COM4.    The Windows 3.0 manual says this is just for 
OS/2 machines, but it seems to work for many clones.

Also note that due to interrupt conflicts, machines without an EISA or Microchannel bus are generally 
not able to use both COM1 and COM3, or COM2 and COM4 simultaneously.

Finally, some video accelerator cards, such as the ATI Vantage and Ultra series, and the S3 89C911-
based cards, use the address normally assigned to COM4, preventing you from using this port 
number.



Using a high-performance 16550 serial port 92-09-15
You can use a 16550-based serial card, or upgrade your serial card to use a 16550 chip instead of an
8250 or 16450 (get the 16550AFN if you're buying a chip only) to improve Windows serial 
communication performance.    This is most noticeable at 9600+ baud rates using advanced protocols 
such as Zmodem.

If you use a Windows-base communications package, the 16550 is automatically enabled.    You can 
disable it, however, by setting

COMxFIFO=off
in the [386Enh] section of your system.ini file, where x is your serial port number (1 to 4).



DOS boxes and 16550 serial ports 92-09-28
For DOS-based applications, the use of the 16550 serial port chip (and its built-in FIFO buffers) is not 
enabled by default.    What you need to do is set

COMxBuff=off
in the [386Enh] section of your system.ini file, where x is your serial port number (1 to 4).    This will 
disable Windows' buffering of that serial port, and allow the DOS app to access it directly.    This is not
recommended for use with Windows-based communication packages!

Another alternative is to use chcomb.386 (replace the device=*combuff line in the system.ini file with 
device=chcomb.386), a shareware device driver which allows you to use a 16550 for both WIndows 
and DOS applications.





SmartDrive and 16550 high-speed transfers 92-09-27
If you use SmartDrive with Windows 3.1, disk writes are cached by default.    While this is generally a 
good idea, this causes a problem with high-speed downloads, since SmartDrive turns off all 
interrupts when it is performing the delayed disk write.    Since the interrupts are turned off, you may 
lose a packet whenever the disk light goes on!    

The easiest workaround is to disable write caching for your download drive.





Disk drives and virtual memory
Virtual memory and swapfiles 92-09-19
Maximum swapfile size 92-09-28
Windows 3.x and Stacker 92-11-09
SCSI controllers
Windows 3.x and large hard disks



Virtual memory and swapfiles 92-09-19
The type of swapfile you select for running in 386 Enhanced mode can have a significant impact on 
your performance within Windows.    

If you have 12 MB or more of memory, you should likely disable swapping completely; this provides 
substantially better performance than either permanent or temporary swapfiles.    You may also be 
able to do this with 8 MB, depending on the size of your disk cache and the number of applications 
(especially DOS applications) you run simultaneously.

If you determine that you do need a swapfile, you should usually use a permanent one.    Permanent 
swapfiles allow Windows to start up much faster than temporary ones, which must be recreated every
time you start Windows.    Permanent swapfiles, however, require contiguous (unfragmented) disk 
space; you may need to compress your disk, using a tool such as Norton SpeedDisk or PC Tools first.



Maximum swapfile size 92-09-28
Windows 3.1 determines your virtual memory limit by rounding the amount of RAM on your system to 
the nearest 4 MB, multiplying by 4, and then subtracting the amount of the system RAM from the 
total.    This is then the maximum amount of virtual memory (swapfile size) you can use, provided you 
have sufficient unfragmented hard disk space (see previous section).

The multiplier of 4 is a default that can be changed by using a 

PageOverCommit= 

setting in the [386Enh] section of the system.ini file.    The multiplier can be from 1 to 20.



Windows 3.x and Stacker 92-11-09
Stacker 2.0 works well with Windows 3.0 and 3.1.    You should, however, follow the guidelines below 
for using Stacker with Windows:

· Never place a permanent swapfile on a stacked disk.
· Never place a temporary swapfile on a stacked disk.
· Never use SmartDrive to cache the stacked volume
· Do use SmartDrive to cache the unstacked volume containing the stacked volume
· Place SmartDrive before Stacker in your autoexec.bat

To enhance your memory usage, you may wish to stack your RAMdrive to provide additional room for 
temporary files (such as the Print Manager's spool files).

Note: Beware that although Stacker will assume that it can compress your data to provide 2x the 
physical storage capacity, it cannot guarantee that, and placing your temporary files on a 
stacked drive (whether a disk drive or a RAMdrive) may cause the stacked drive to run out of 
room unexpectedly if the compression ratio does not reach 2x (you may wish to read up on 
this in your Stacker documentation).    If this happens, Windows will experience a catastrophic
disk error    and I think we can all agree that that's not a pleasant experience!



SCSI controllers
If you have a bus-mastering SCSI adapter such as the Adaptec 1542, you should be installing the 
aspi4dos.sys ASPI driver (provided with your controller, or available from Adaptec's BBS at (408) 
945-7727) as the first device in your config.sys.    Using the ASPI driver drops the requirement for 
SmartDrive descrivbed below.

Normally, in 386 enhanced mode, Windows 3.x supports only ST-506, ESDI and IDE disk controllers.  
If you have a SCSI controller, you need to load SmartDrive in order to allow Windows to recognize 
your hard disk    and with Windows 3.1, you should use the /double_buffer option.    Do not disable 
double buffering in a bus-mastering SCSI drive unless you're using the ASPI driver described above.

As a third alternative, you may insert the following line in your system.ini file, in the [386enh] section:
VirtualHDIRQ=off

Finally, some people report having problems with permanent swapfiles on SCSI drives using 
Windows 3.0.    



Windows 3.x and large hard disks
In rare cases, there are problems with using Windows 3.0 on large hard disks.    Your system may be 
at risk if:

· You are using third-party partitioning software, such as:
· Disk Manager (dmdrv.bin)
· InnerSpace (edvr.sys)
· SpeedStor (sstor.sys or hardrive.sys)
· Vfeatures Deluxe (fixt_drv.sys)

· and you are using SmartDrive (smartdrv.sys) as your disk cache 
· and your hard disk has more than 1023 cylinders

If your hard disk has fewer than 1024 cylinders, you may still be at risk if the first two conditions hold 
true, you are using DOS 3.30 or later, and your hard disk is not supported by your BIOS.    To avoid 
problems, you can either stop using SmartDrive, or reformat your disk using the DOS FDISK utility.

There are no problems with large partitions created by the FDISK program included with MS-DOS 4.0
and some versions of MS-DOS 3.3.

If you are still having problems, call Microsoft Technical Support at (206) 454-2030.



Troubleshooting
One essential tool for troubleshooting Windows 3.x problems is Microsoft's Windows Resource 
Toolkit.    This combination of a comprehensive reference and some utility tools is priced at around 
$30, and can't be beat for value.    If you are responsible for keeping a number of Windows systems 
running, run, don't walk, to the nearest phone and order it now!

The toolkit is also freely available in Word for Windows format from ftp.cica.indiana.edu (and its mirror
sites); while this version is complete, it is large, and will take significant time to ftp and download (not 
to mention print!).
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BMP wallpaper won't display correctly
Some of the possible reasons are:

· Your .bmp file is corrupted.    Try reading it into Paintbrush to verify that it is readable.
· You are trying to display a bitmap with more colors than your video driver supports for 

example, 256 colors with a 16-color driver, or 16M colors with a 256-color driver).
· You have insufficient memory to display the bitmap.    A 800x600x16 bitmap requires 256K of 

memory; 1024x768x256 would require 768K!

For 256-to-16 color dithering, you may try using a utility such as PaintShop Pro.



Frequent GPFs (General Protection Faults)
If you are experiencing frequent Windows 3.1 crashes, try starting Windows with the command

win /d:xsv

If the GPFs do not appear, add the line
VirtualHDIRQ=off

to the [386Enh] section of your system.ini file.    If the GPFs contine, try
win /d:xs

If the GPFs do not appear, add the line
SystemROMBreakPoint=false

to the [386Enh] section of your system.ini file.    If the GPFs contine, try
win /d:x

If the GPFs do not appear, add the line
EMMExclude=A000-EFFF

to the [386Enh] section of your system.ini file.    While this will get Windows running more reliably, 
you should probably try to narrow down the range of memory that actually has to be excluded.



File Manager won't format floppies
If you are having trouble formatting floppies from File Manager, try adding one or more 

DEVICE=DRIVER.SYS /D:# /F:#
lines to your config.sys; see your DOS manual for details.



Invalid system version; reinstall the 386 enhanced version fo Windows
If you get the above message when starting a DOS session, you are likely using a display driver 
written for Windows 3.0.    Updating it to a 3.1 compatible version    should make the problem 
disappear.



Mouse hangs when using communications software
This problem is usually caused by a mouse and a modem being on the same serial port pair (either 
COM1/COM3, or COM2/COM4).    Each pair shares a common interrupt due to restrictions of the 
original IBM PC architecture, and so can not be used simultaneously.

If you are experiencing this problem, you should move either your modem or mouse a different serial 
port.



Parity errors with Windows 3.1 92-09-19
Parity errors are real, and detected reliably by Windows 3.1 (Windows 3.0 ignored them for the most 
part).    Unfortunately most memory test programs do not properly test 32-bit memory accesses, and 
thus do not detect all possible memory problems.    Environments such as Windows 3.1, Windows NT,
Unix, Xenix and OS/2 2.0, however, do exercise this aspect    and, as a result, report memory 
problems where the memory testers don't catch them.

Below are some of the possible causes for parity errors, in approximate order of likelyhood:
· Defective memory module
· 80ns memory where 70ns is required
· Two different speeds of memory modules
· DMA or memory conflicts
· Outdated BIOS
· Defective DMA on the CPU chip

If you're willing to play with fire and gasoline (if, for example, you have 8-bit memory with no parity 
bit), you can disable parity checking by removing or commenting out the following line in the [386Enh]
section of your system.ini file:

device=*parity

Note that this will disable your parity checking completely and may cause unexpected crashes
or errors if your memory has parity errors!



Performance deterioration in a 386 Enhanced mode DOS session
The most likely cause of this type of a problem is slow memory.    If your onboard memory is accessed
with basically no wait states, but you have a slower memory expansion card, your machine will run 
slower whenever it is using those higher memory addresses.    This will generally happen when you 
start a DOS session, and often result in 30-50% performance reductions using various benchmarks.    
The performance is actually also reduced within Windows, but it's difficult to notice this due to the lack
of a suitable benchmark.    The proper cure for this problem is to either upgrade your memory 
expansion card, or to correct whatever problem is causing your machine to access extended memory 
with such poor problem.

DOS application performace is also degraded by using a .PIF file (such as the default .PIF) with the 
Monitor Ports option enabled, but to a much smaller degree.    With Monitor Ports disabled, DOS 
session performance should be within 5-10% of the performance under bare DOS.



Problems creating a permanent swapfile in Windows 3.0
First of all, you must be running in real mode to be able to create a permanent swapfile.      Second, 
You must not have any SUBSTed drives or Windows won't create the swapfile.    Once the swapfile 
has been created, you can re-SUBST your drives (although the use of SUBST is not recommended in
general).    You also can't create a permanent swapfile on a drive partitioned with third-party software 
such as SpeedStor.    

If you are installing on a Novell client, you must first disable the receive network messages feature 
(using the network icon in the Control Panel) and reboot.    Once you have installed the swapfile, turn 
messages back on again.



Using a slow expansion memory board with Windows 92-11-11
If some of your memory is on a slower memory expansion board (such as a standard ISA bus 
memory board, operating at 8 MHz in a 33 MHz system, you may experience serious performance 
deterioration as soon as Windows starts using the slower memory on the expansion board.    (For 
example, see section Performance deterioration in a 386 Enhanced mode DOS session.)

Unfortunately Windows 3.1 does not allow you to specify memory ranges to be used for a RAMdisk or
disk cache, and thus you can't control which memory gets used first.    In this case, the best solution is
to use QEMM-386, which allows you to do just that.    Place your RAMdisk and disk cache in the slow 
memory (they will not suffer a significant performance drop), and leave the fast memory on the 
motherboard available for Windows' use.



Windows 3.0 refuses to run without a file called WINA20.386
Quoting from the MS-DOS 5.0 readme.txt file:

4.3 WINA20.386 File

Setup installs a read-only file named WINA20.386 in your root directory.    If you move the 
WINA20.386 file to a different directory, do the following:

· Add a SWITCHES=/W command to your CONFIG.SYS file.
· Add a DEVICE=[drive:][path]]WINA20.386 command to the [386Enh] section of your 

Windows system.ini file.

Windows 3.1 does not require this file to be present.



Windows 3.1 hangs or crashes during startup
Try starting Windows with the command line 

win /b

If it repeats the same crash or hang, take a look at the file bootlog.txt in your Windows directory.    It 
will have two lines such as 

LoadStart = SYSTEM.DRV
and

LoadSuccess = SYSTEM.DRV
for every driver succesfully loaded; the culprit driver will show a line such as

LoadFail = WIN3-64S.DRV Failure code is 05

If it's a standard Windows driver, try reloading it from diskettes; otherwise, for a third-party driver, try 
to locate an updated driver either from cica, your supplier or direct from the manufacturer.



Windows 3.1 hangs or waits a long time on exit
Windows 3.1 tries to reset the mouse driver on exit, and some IBM PS/2 models have great difficulty 
with this procedure, timing out only after an extended wait.    In order to avoid the problem, add the 
line

InitPS2MouseAtExit=False

to the [386Enh] section of your system.ini file.



Windows 3.1 Resource Kit installation
The most common WRK installation problem is an excessively long path.    If you have problems, try 
reducing the length of your path for the installation, and you should be OK.



Windows 3.x waits a long time on startup
One possible reason is the use of a serial mouse on COM2 instead of COM1.    If you have a serial 
mouse, Windows will first attempt to find it (with great persistence) on COM1, before it looks on 
COM2.    If your mouse is on COM2, move it to COM1.

Using a temporary swapfile instead of a permanent one for 386 enhanced mode also slows down the 
startup process, but not to even nearly the same extent as the serial mouse problem.

With Windows 3.0, it has also been reported that adding too many fonts through the Control Panel will
drastically slow down the startup, and with both Windows 3.0 and 3.1, a very large number of ATM 
fonts will also slow down the startup process.
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DOS in a window
You can run a both the standard DOS command interpreter (command.com) and other DOS 
applications from within Windows.    In Real mode, you are limited to a single session.    In Standard 
mode, you can have multiple sessions, but they must still run full-screen.    In 386 Enhanced mode, 
you can have multiple sessions, and they can run in a window.

You can control the starting up in a window vs. full-screen by setting up a .pif file for the program 
(command.com    or any other DOS program).    You can also switch the state by pressing Alt-Enter.



Lotus 1-2-3 in Windows
Lotus 1-2-3, versions 1.x, 2.x and 3.1 run in all modes, but do not support any of the features of the 
Windows environment.    For all intents and purposes, version 3.0 doesn't run under Windows. 

If you want to use a spreadsheet in the Windows environment, however, you will be best off buying a 
real Windows spreadsheet such as Excel, WingZ, CA-Compete! or 1-2-3 for Windows.



Reducing the amount of "jerkiness" in DOS window updating
Windows 3.1 updates the DOS windows by default every 50 ms.    To increase the update frequency, 
specify another update interval (such as 20 ms) by adding a line to the [386Enh] section of 
system.ini:

WindowUpdateTime=20
A smaller interval will provide smoother updates but impose a higher load on the system.



Extended memory in DOS sessions
After you run Windows, a utility such as Norton SI will often report that you don't have any extended 
memory.    This is not a bug, but rather a result of the Windows memory management system..    
Windows requires applications to access extended memory using one of two mechanisms, known as 
"XMS" and "DPMI".    These mechanism are implemented in himem.sys and emm386.exe.    If you 
have device=himem.sys in your config.sys, the first XMS call (by Windows or SmartDrive, for 
example) will transfer control of the extended memory to himem.sys, and thus make it inaccessible 
to non-XMS/non-DPMI applications.



Changing the font size for a DOS window
All video drivers updated for Windows 3.1 allow on-the-fly font changes; to get the same functionality 
using older 3.0 drivers (in Windows 3.1), add the line

FontChangeEnable=1
to the [NonWindowsApp] section of the system.ini file.    If you experience strange cursor behaviour 
or missing characters, remove the line from system.ini.

There are also alternate Windows 3.0 DOS fonts available at ftp.cica.indiana.edu.



Changing the number of lines inr a DOS window 92-11-15
To use more than 25 lines in a DOS window, add the line

ScreenLines=50
to the [NonWindowsApp] section of the system.ini file.    

If your screen doesn't quite fit 50 lines in a DOS window with a decent font, you may want to follow 
this procedure:

· Use a VGA font editor (such as VFONT) to create a DOS VGA screen font with more than
25 lines.

· Start up a DOS session (in a window)
· In that window, change the font (and thus screen size) to your new font/size.    Voila!



Mouse in a DOS window
In Windows 3.0, if you are running a DOS application in a window, Windows will retain control of the 
mouse for cutting and pasting.    You can use a mouse in a full-screen DOS session if you install a 
mouse driver by running mouse.com (either before starting Windows, or inside the DOS session), or 
by including 

device=mouse.sys
 in your config.sys file. If you're running WordPerfect 5.1 inside Windows, WordPerfect must be 
started full-screen in order to detect the mouse.    Once it has started, you can use Alt-Enter to run in 
a window, if you wish.

In Windows 3.1, the mouse will automatically work in a DOS window if you have a video driver which 
has been updated for 3.1.    Old 3.0 drivers do work, but they do not by default provide mouse 
functionality inside DOS windows, although you can force them to do so by adding the line

MouseinDosBox=1
to the [NonWindowsApp] section of the system.ini file.

If you have a Microsoft mouse, you should use the mouse driver version 8.20, included on the 
Windows 3.1 disks, named mouse.co_ and mouse.sy_. Expand these files using expand.exe (also 
included on the disks) before using them.



TSRs in DOS sessions
Some TSR (Terminate and Stay Resident) programs will not work if you install them before running 
Windows.    Some of them will not work if you install them inside a DOS session.    Generally the best 
idea is to avoid TSRs completely unless you absolutely have to have them.    

See also the description of winstart.bat in the Windows *.txt files.



VGA graphics in a windowed DOS session
Windows 3.1 will support VGA graphics in a windows DOS session if you have the correct display 
driver.    True Windows 3.1 display drivers (such as the standard SuperVGA driver) will do this, but 
some partial implementations may not.



Troubleshooting DOS applications
Out of Environment Space
Protected-mode software
Corrupted diskettes when copying files in a DOS session



Out of Environment Space
When Windows starts up a DOS session, it by default gives it an environment of 224 bytes, or the 
space required to hold your current environment, whichever is larger.    If you need more space, there 
are two methods of circumventing this.    In order of desirability:

·  Use a .pif file for each DOS application you run.    
In this you can specify the environment size by using the /e:nnn option (see your DOS manual).    You 
will need a separate .pif file for each program (although in Windows 3.1 you can create a _default.pif, 
which is used by all DOS applications which do not have their own .pif files).    You can just create a 
command.pif with a suitable /e:nnn, and then specify in the win.ini a line such as

[Extensions]
bat=command.pif ^.bat        // for DOS users
ksh=sh.exe ^.ksh             // for MKS users

With this, you can create batch file icons freely, and still get the options specified in command.pif or 
sh.pif.

· Use a dummy variable 
By specifying a dummy variable (such as DUMMY1=xxxxx...)    before starting
Windows, you can reserve some space in the environment.    Then, as the first thing in each 
command.com session, do

set DUMMY1=
to reclaim the space used by DUMMY1 for use by other environment variables.



Protected-mode software
Many protected-mode applications currently on the market use an extended-memory interface called 
VCPI (Virtual Control Program Interface), which is incompatible with Windows' DPMI (DOS Protected 
Mode Interface).    Microsoft went against an established standard in choosing DPMI, but there are 
valid technical reasons why VCPI was not chosen for Windows.    

At this point, you have three choices: 
· Run your protected-mode software under DOS

This means that you must NOT use Windows or SmartDrive before running your VCPI software, and 
may require you to have two different config.sys files.

· Plead with your software developer
Call up the software vendor and ask them whether they are developing either a Windows-based 
version, or, at the minimum, one which uses DPMI instead of VCPI.    They should already be working 
on it anyway, given the momentum that Windows 3.x has.

· Buy QEMM/386 or 386Max
Both of these packages provide VCPI.    You'll be able to run your protected-mode software as well as 
Windows 3.0 and 3.1.



Corrupted diskettes when copying files in a DOS session
If you are getting corrupted diskettes with a 0xff as every other byte when copying files to a floppy 
within a DOS session, the most likely cause is an expansion board using the same memory area also 
used by Windows for EMM.    You should check that you EMMExclude all areas used by your cards.

The Video-7 1024 SVGA board needs a more radical measure: you need to change a jumper to do all
ROM decoding in cooo - c7ff, and change a DIP switch to force 8-bit ROM access.
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QEMM/386 and DesqView/386
You can use versions 5.0 of QEMM/386 and below with real-mode Windows 3.0 only.    However, 
QEMM/386, versions 5.1 and higher, provides XMS services for Windows, thus allowing Windows to 
run in all modes under QEMM/386, plus providing compatability with VCPI applications.

Windows will run in Standard (Windows 3.0 and 3.1) and Real (3.0 only) modes as a DesqView/386 
task.



MKS Toolkit: setting up
There are two possible problems with running Windows from the MKS Toolkit.    First, with versions up
to and including 3.1c of the Toolkit, the use of login.exe precludes the use of Windows 3.0 in any but 
the real mode.    To avoid this, have your machine boot directly into the Korn shell or command.com 
(you may use init.exe if you wish).

Second, somebody at Microsoft had a brain fade, and Windows gets confused if it is started with a 
forward slash path.    Thus, if you simply type "win" in Korn shell, the shell invokes Windows with 
something like

c:/usr/windows/win.com

and Windows doesn't know where to find itself!    To cure this, specify a shell alias for Windows: I use

alias -x win='c:\\usr\\windows\\win.com'

Note that the double backslashes are necessary for the Korn shell, even inside the single quotes.

The newer versions of MKS Toolkit allow (standard and 386 enhanced mode) Windows to run directly 
from the login: prompt; but they still won't let you run standard/386 enhanced Windows from the shell 
(if you used login). An updated version of init.exe is available from MKS for users of older versions of 
the MKS Toolkit.



MKS Toolkit: maximizing DOS session memory 92-10-05
If you run MKS Toolkit by starting up init.exe from config.sys, and then starting the shell from 
/etc/inittab, you will likely find that there isn't much memory available in the DOS (shell) sessions you
start from inside Windows.

One way to address this is to start up Windows immediately upon booting, avoiding loading the shell 
into the valuable DOS low memory.    There are at least two ways of doing this cleanly:

As the last line in your profile.ksh, add the command 
exec c:\\windows\\win.com    

(or whatever the path is to your Windows directory).    Using the exec command retains the 
environment you have set up in your profile.ksh and environ.ksh files, but overlays the shell 
memory with Windows, avoiding memory loss.

Since the startup script executes Windows at the end, make sure that you so not run sh -L from
Windows, as this would attempt to restart Windows.

Given that command.com    uses much less memory than the shell, you can specify (as the last 
line in /etc/inittab, instead of starting up the shell) the following:

ms;35;respawn;c:/dos/command.com /c c:\etc\init.bat 

Then, in /etc/init.bat, specify all your essential environment variables, and as the last line start up
Windows.    This method wastest a few kilobytes of low memory compared to hte first one, but 
allows you run sh -L without risk.



MS-SH
The basic problem is the MS-SH swap setting.    In Real mode, you will need to use swap disk.    In 
Standard mode, you can also use swap extend, but you will have to specify at least 200K of XMS 
memory in the MS-SH .pif file.    Alternatively, if you are using Standard or 386 Enhanced mode, you 
can use swap ems, but again you will need to specify at least 200K of EMS memory in your .pif file.    
A bug in the current (as of this writing) version of MS-SH prevents swap extend from working in 386 
enhanced mode; MS-SH will always crash with a panic error.

With Windows 3.1, swap xms works as intended, and is the appropriate setting.



Windows Tips, Tricks and Secrets
General 92-09-19
Program Manager 92-11-02
Windows Accessories 92-09-27
Changing default directories
Fonts 92-11-11
Applications 92-11-15
Gang screens



General
Changing or bypassing the startup logo
Automatically opening applications on startup, with predefined window positions
Changing the font used for the icon labels 92-09-19
Limiting the size of the temporary swap file
Making Windows 3.x act like 2.x runtime
Swapping the Ctrl and CapsLock Keys



Changing or bypassing the startup logo
To bypass the logo, you can start Windows with the command line such as 

win : 
Be warned, however, that some people have had problems with this.    Also, skipping the startup logo 
does not speed up the Windows startup process.

To change the logo to something else, you need to first create a .RLE file (using a graphics utility 
package), with no more than 16 colours, and not exceeding the VGA 640x480 screen resolution, and 
no more than 64K in size.    Once you have this file, say mylogo.rle, enter the following command in 
your system subdirectory:

copy win.cnf/B+vgalogo.lgo/B+mylogo.rle/B win.com
If you use CGA or EGA, limit the .RLE file to the appropriate resolution, and replace the vgalogo 
above with cgalogo or egalogo.



Automatically opening applications on startup, with predefined window positions
You can load applications automatically in two ways:

· By adding them to the Startup group in Windows 3.1 Program Manager.    To run start 
them as icons, check the Run iconized checkbox in the File » Properties dialog for the 
program.

· By specifying them on the load= or run= line in win.ini.    This will load the specified 
applications, respectively, either with their default window sizes, or as icons.

If you need specific window sizes or positions, you will need to use another utility, either shareware 
package (such as Layout, Command Post or Aporia) or a commercial one (such as Batchworks, 
Bridge or NewWave).



Changing the font used for the icon labels 92-09-19
To use 10-point Arial (substitute your own favorite below), add the following two lines to your 
[Desktop] section of your win.ini file:

Icontitlefacename=Arial
Icontitlesize=10

A shareware Control Panel utility, More Control also gives you control over the icon fonts.



Limiting the size of the temporary swap file
In Windows 3.1, you can add a line such as 

MinUserDiskSpace=4096
to the [386Enh] section of the system.ini file to limit the temporary swap file's size.    The above line 
doesn't actually set the size of the swap file, but rather limits its growth to always retain at least 4096 
KB (4 MB) of available disk space for your and your applications' own use.



Making Windows 3.x act like 2.x runtime
The Windows 2.x runtime version would start Windows from the DOS prompt, and exit back to DOS 
when you exit the application.

You can do this as follows (the example is for Excel; others are similar):

· Create a new directory called c:\excel (it doesn't have to be distinct; it could be your normal 
Excel directory, as long as it's not the main Windows 3.x directory).

· Copy the following to the new directory from the Windows directory:
win.com
win.ini
system.ini

· In the new directory modify the [boot] section of system.ini by changing the shell= line to 
point to the one and only program you want to run.    The original line should read:

shell=progman.exe
and the modified line should be something like: 

shell=c:\excel\excel.exe.   
Remember to type the complete fileid of the program to be executed, including the .exe suffix.

· To execute the dedicated Windows session just put the new directory ahead of the normal 
Windows directory in your path and issue the 'win' command, or start Windows with the 
command 'c:\excel\win'.    What we're doing here is making Windows think it's running on a 
network where the actual executable files etc. are on a network server, and only the basic 
control files (and win.com) are on the user's local disk.    

Note that this technique isolates any changes in win.ini and system.ini made in the 
dedicated task from any changes made in normal Windows; this may or may not be 
desirable.    If you need to keep the two flavors of Windows in sync you'll have to provide an 
outboard copy function to refresh the files.



Swapping the Ctrl and CapsLock Keys
You need to use a different keyboard driver.    A good one comes with the distribution of Kermit for 
Windows, available either from cica or from the official Kermit archive at watsun.cc.columbia.edu.



Program Manager
Saving Program Manager settings without exiting Windows
Starting Windows without activating the applications in the Startup group
Starting an application in a different directory
Changing the title of the Program Manager window 92-09-28
Changing the program icon
Creating your own icons 92-09-28
Changing the font used for the icon labels 92-09-19
Changing the WinHelp keyword colors 92-09-27
Creating your own wallpaper
Previewing PostScript output 92-11-02
Restricting the Program Manager 92-09-19



Saving Program Manager settings without exiting Windows
In Windows 3.0, the trick is to try to select File » Exit with a DOS sessionactive; Windows will save 
the settings, and then refuse to exit.    

In Windows 3.1, you can press Alt+Shift+F4 at any time (while you are in Program Manager) to save 
the settings.



Starting Windows without activating the applications in the Startup group
You can do this by holding down the Shift key when the Windows startup screen appears, and then 
releasing it once Program Manager is active.



Starting an application in a different directory
To start up a Windows application in a default directory other than the Windows directory (or 
application executable directory), you have a number of choices:

· In Windows 3.1, set the Working Directory under File Properties for the application.

· Create a auto-execute macro for that application, which will change your directory upon 
startup.

· Specify your application's path in Program Manager as something such as d:\u\personal\
letters\winword.exe.    As long as the application is on your path, it will be started as usual, but
with the default directory being the one you specified in Program Manager.    Note that 
Program Manager will complain of this when you enter the path (and may require you to 
manually select an icon), but it will work.

· Create a dummy document for your application in the desired directory.    As long as you have
your application listed under [Extensions] in your win.ini file, starting that document from 
Program Manager (either with File » Run or by adding it as an icon to a group) will then start 
the application with that document loaded, and in the correct directory.

.
·  For Word for Windows 2.0, add the line

Doc-Path=pathname
into the [Microsoft Word 2.0] section of your win.ini file.    This will cause Word to start up in 
the specified directory every time.



Changing the title of the Program Manager window 92-09-28
In Windows 3.1, you can specify the title of the Program Manager window by adding a Program 
Manager icon to your Startup group.    Windows will not start up a second copy of Program Manager, 
but will use the title you specify in File » Properties for the icon.



Changing the program icon
Choose the item in Program Manager, and then select File Properties. Click on Icon..., and then enter
the name of the file containing the new icon.    

If the icon file is a .DLL or .EXE containing multiple icons, you can either scroll though the available 
icons (in Windows 3.1) or cycle through them by clicking Next Icon (Windows 3.0).    After selecting 
the correct icon, click OK, and then OK again.    You can also use icons from other programs by the 
same method: just specify the name of the .exe file instead of an .ICO or .DLL file.

The icon that is displayed by the application when it is minimized is controlled by the application.    It is
not normally possible to change that; however, several workarounds exist for changing the icons of 
running DOS applications.    

· Windows 3.1 will display the selected Program Manager icon for each running DOS 
application.

· In Windows 3.0 you can use the iinject or puticon utility to replace the standard DOS icon,
which is contained in winoa286.mod and/or winoa386.mod.    

· The IconFixer utility monitors your DOS applicationsin Windows 3.0, and updates their 
icons as you minimize them, allowing you to have different icons for different DOS 
applications. 

 All three utilities are available from ftp.cica.indiana.edu.



Creating your own icons 92-09-28
You can create your own custom icons with either IconDraw (shareware), Icon12 (shareware), 
Tamr11 (shareware), SDKPaint (a part of the Windows SDK) or Resource Workshop (a part of 
Borland C++).    Simply draw your icon, and save it as an .ICO file.



Changing the font used for the icon labels 92-09-19
To use 10-point Arial (substitute your own favorite below), add the following two lines to your 
[Desktop] section of your win.ini file:

Icontitlefacename=Arial
Icontitlesize=10

A shareware Control Panel utility, More Control also gives you control over the icon fonts.



Changing the WinHelp keyword colors 92-09-27
To change the keyword colors in your Windows help files, you can add some or all of the following 
lines to the [Windows Help] section of your win.ini file:

JumpColor=255 0 0
PopupColor=0 0 255
IFJumpColor=128 0 0
MacroColor=0 128 0
IFPopupColor=0 0 128

The arguments are the intensities of Red, Green and Blue, respectively, with
legal values between 0 and 255. This means that JumpColor (above) would be
an intense red.



Creating your own wallpaper
You can save a .msp file as a .bmp from Windows Paintbrush.    You can convert a .gif file to a .bmp 
using the gif2bmp utility from cica.    wingif will also do a good conversion, including dithering 256-
color images to 16 colors (rescale before dithering!).    A third, and the most flexible, conversion 
program is PaintShop Pro, which will do color conversions (16M, 32K, 256 and 16 colors), many 
format conversions, scaling and clipping.    Both wingif and PaintShop Pro are shareware, and 
available at ftp.cica.indiana.edu.

A JPEG-format file can also be converted to a walppaper bitmap by first uncompressing it with the 
cjpeg/djpeg utility (free, available at wuarchive.wustl.edu and other sites) to a .gif, and then using one
of the utilities above to convert the .gif to a .bmp.



Previewing PostScript output 92-11-02
To preview PostScript output on Windows, you can use GhostScript, a free utility from the GNU 
project.    The current version, 2.52, can be found on ftp.cica.indiana.edu and other archive sites as 
GS252WIN.ZIP.



Restricting the Program Manager 92-09-19
If you want to prevent a user from changing the Program Manager configuration, you can insert a 
combination of the following lines into progman.ini:

NoRun=1 Disables the Run command
NoClose=1 Disables the Exit Windows command
NoSaveSettings=1 Disables the Save Settings command
NoFileMenu=1 Removes the File menu
EditLevel=(see below) Sets the edit restriction level

The following are the EditLevel restrictions:
1 Disables creating,deleting and renaming groups
2 As 1, plus disables creation/deletion of program items
3 As 2, plus disables changing program item command lines
4 As 3, plus disables changing program information



Windows Accessories
Recording more than 60 seconds of sound with Recorder
Converting cardfiles to ASCII text 92-09-27
F5 in Notepad
Keypad in Windows Terminal
Windows 3.1 Clock limitations
Can't open TEMP.WRI (or similar) when starting a desk accessory



Recording more than 60 seconds of sound with Recorder
If you want to record, say, three minutes, follow this procedure:    
· Record 60 seconds (Recorder will stop).    
· Immediately record again for 60 seconds. 
· Repeat one more time.    
· Drag the scroll bar thumb all the way to the left
With this procedure, you will be able to record 180 seconds of sound.    Repeat more times if you 
need more than 3 minutes of sound.



Converting cardfiles to ASCII text 92-09-27
To convert a cardfile to a text file, use the WinCrd utility, available from ftp.cica.indiana.edu.



F5 in Notepad
F5 in Windows 3.0 Notepad inserts only a date and not the time as well    it's a known bug.    And it's 
fixed in Windows 3.1.



Keypad in Windows Terminal
Press ScrollLock to toggle the keypad between local and remote mode. The default is local mode.



Windows 3.1 Clock limitations
The Windows 3.1 clock is limited to one instance (simultaneously running copy) by design, as it 
retains the position and size you last specified for it.    You can, however, run any number of Windows 
3.0 clocks that you want in 3.1.    As an alternative, you may want to take a look at the TimeFrame 
freeware program from ftp.cica.indiana.edu, which places the current time in the title bar of the active 
window. 



Can't open TEMP.WRI (or similar) when starting a desk accessory
A message similar to this one is likely caused by an invalid definition of the TEMP environment 
variable in your autoexec.bat.    Havign a trailing space on the definition line can cause various 
Windows applications to generate invalid temporary filenames similar to the one noted.    Correct the 
problem by making sure there are no trailing blanks.



Changing default directories
Bitmaps
Fonts
Icons



Bitmaps
You cannot move the bitmaps from the Windows directory unless you use a utility program such a 
PaperBoy.



Fonts
To move your TrueType fonts to a different directory, follow the procedure below:

·



Icons
Yoy may place your fonts in any directory you wish, as long as you update your Program Manager's 
File » Properties dialogs to point to the correct location.



Fonts
TrueType, ATM and FaceLift
Converting Font Formats
Viewing available fonts
Foreign character sets
Converting Macintosh Type 1 (ATM) fonts to Windows
Replacing your System font with a serif font 92-11-05
Zip code bar code fonts 92-11-11



TrueType, ATM and FaceLift
In case you were wondering whether Bitstream FaceLift, Adobe Type Manager (ATM) and TrueType 
really work    yes, they do.

Here are some things to consider:
· TrueType is included free with Windows 3.1 (and Apple System 7.0).    It's somewhat more 

flexible than ATM in its font description capabilities, and renders very fast to LaserJet II-
compatible printers.

· ATM uses the ubiquitous Type 1 fonts, which are widely available, both commercially and at 
FTP sites.    It has had some compatability problems, but version 2.0 is fully compatible with 
Windows 3.1.

· FaceLift provides the most user control of three, but has the poorest native font support.    
Version 2.0, however, can use Adobe Type 1 fonts directly.    It also lets you generate LaserJet
soft fonts for higher printing speeds.

At street prices not much above $50, ATM and FaceLift were definitely worth their prices, at least 
before Windows 3.1.    Now, with the free TrueType, you may wish to postpone your ATM or FaceLift 
purchase until you have determined whether TrueType will satisfy your needs.



Converting Font Formats
There are at least two packages available to convert between Type 1 (ATM) and TrueType formats: 
AllType ($79) and FontMonger ($99).    AllType, however, imposes its own copyright on any converted 
fonts, as well as doing a generally unsatisfactory job of coverting from ATM to TrueType.    

Macintosh TrueType fonts are also directly compatable with Windows (you only need to strip off the 
resource fork from the Mac file).



Viewing available fonts
At least three shareware/freeware programs claim to be able to do provide a listing of all available 
fonts: Fonter, FontShow and Compose are all available at ftp.cica.indiana.edu.



Foreign character sets
To create Cyrillic documents, you may wish to use the shareware CyrWin package, available from 
ftp.cica.indiana.edu as well as other sources. Cyrillic fonts are also available from Data-Cal (602-545-
1234) and East West Trade Consulting (+49-8230-4925 in Germany).

Hebrew fonts are also available from Data-Cal.    Also, the WinGreek package at ftp.cica.indiana.edu 
contains Hebrew fonts (for screen and LaserJets; an ATM version is under development).

I am not aware of any Arabic fonts, but Eastern Language Systems in Utah (801-377-2200) has an 
Arabic word processor called AlKatiib, as well as a Persian one called Vazhe Negar.

Data-Cal's WorldFont for Windows package also includes some Japanese language support, and a 
Japanese font called Shorai is reputed to be available on FTP sites.



Converting Macintosh Type 1 (ATM) fonts to Windows
Thanks for this procedure to Norman Walsh, the maintainer of the comp.fonts FAQ.

Converting Macintosh Type1 fonts into PC Type1 fonts can be done using purely free/shareware 
tools.    I've outlined the procedure below.    Make sure you read
the "readme" files that accompany many fonts.    Some font authors specifically deny permission to do
cross-platform conversions.

The tools you need:
xbin xbin23.zip in /pub/msdos/mac on oak.oakland.edu (or other mirrors)
unsit unsit30.zip in /pub/msdos/mac on oak.oakland.edu
uncpt ext-pc.zip in /pub/pc/win3/util on ftp.cica.indiana.edu
refont refont11.zip in /pub/pc/win3/fonts on ftp.cica.indiana.edu
bmap2afm bm2af01.zip in /pub/norm/mac-font-tools on ibis.cs.umass.edu

xbin converts Mac BinHexed files back into binary format.    BinHex is the Mac equivalent of 
uuencoding: it translates files into hexidecimal digits so that mailers can send them around 
without difficulty.    It also aids in cross-platform copying.    BinHexed files generally have filenames
of the form "xxx.yyy.HQX".

unsit explodes Stuffit archives.    Stuffit archives generally have filenames of the form "xxx.SIT".

uncpt exploces Compactor archives.    The ext-pc implementation is called extract and does not 
require Windows (even thought it's in the Windows section on cica).    Compactor archives 
generally have filenames of the form "xxx.CPT".

refont converts Mac type1 fonts into PC type1 fonts.

bmap2afm constructs AFM files from the metric information contained in Mac screen fonts 
(.bmap files).    The screen font files do not have any standard name (although they frequently 
have the extension .bmap).    The screen fonts have file type "FFIL" which, in combination with 
some common sense, is usually sufficient to identify them.

It's probably a good idea to check with archie for closer sites if you're not in North America.    
These tools run under MS-DOS.    xbin and unsit can also be run under Unix.

How to do it:
Collect the Mac fonts from the archive or BBS of your choice.    Most of these files will be in 
BinHexed format.    As a running example, we'll use the imaginary font "Plugh.cpt.hqx".    When 
you download this font to my PC, you would use the name "PLUGH.CPX".    The actual name you
use is immaterial.

Run xbin on PLUGH.CPX.    This will produce PLUGH.DAT, PLUGH.INF, and PLUGH.RSR.    The
data fork of the Mac file (the .DAT file) is the only one of interest to
us, you can delete the others.

If the original file had been "Plugh.sit.hqx", we would be using the unsit program.    Since we 
chose a .cpt file for this example, I'm going to run uncpt..    Run uncpt on PLUGH.DAT.    You'll 
want to extract the AFM file (if present), the documentation or readme file (if present), and the 
Type1 outline file.    The AFM and README files will be in the data fork of the archive file.    The 
Type1 outline will be in the resource fork.    The AFM and README files have Mac "TEXT" type.    
The Type1 outline file has "LWFN" type.    Use the docs for uncpt and unsit as a guide.    If you 
got this far you probably won't have much difficulty.

If the font does not contain an AFM file, extract the screen font.    Screen fonts frequently have the



extension .bmap and are "FFIL" type files.    Use Bmap2AFM to construct an AFM from the screen
font.    If the archive does contain an AFM file, it's safe to bet that the author's AFM will be better 
than the one created by Bmap2AFM.

Finally, run refont on the Type1 outline that you extracted above.    The result should be an 
appropriate PC type1 outline.    refont will create a PFM file for you from the AFM file, if you 
desire.



Replacing your System font with a serif font 92-11-05
Thanks to Peter Karrer <pkarrer@bernina.ethz.ch>.

Here's a way to produce your own system font from the MS Serif font (similar to Times Roman) in 
Windows 3.1. No warranties of course...

If you're using "small" fonts (fonts.fon=vgasys.fon in system.ini):

Make sure you have VGASYS.FON, 7280 bytes, and SERIFE.FON, 57936 bytes.
Use debug to do the following:
C:\WIN\SYSTEM> debug serife.fon
- nmyvgasys.fon
- m15b6 l14b3 100
- rcx
CX E250
:14b3
- w
Writing 014B3 bytes
C:\WIN\SYSTEM> debug vgasys.fon
- nmyvgasys.fon
- l6b6
- rcx
CX 14B3
:1C70
- w
Writing 01C70 bytes
- q

In your system.ini file, replace fonts.fon=vgasys.fon with fonts.fon=myvgasys.fon.

If you're using "large" fonts (fonts.fon=8514sys.fon in system.ini):

Make sure you have 8514SYS.FON, 9280 bytes, and SERIFF.FON, 81728 bytes.
Use debug to do the following:
C:\WIN\SYSTEM> debug seriff.fon
- nmy8514sy.fon
- m1b36 l1c20 100
- rcx
CX 3F40
:1c20
- rbx
BX 0001
:0
- w
Writing 01C20 bytes
C:\WIN\SYSTEM> debug 8514sys.fon
- nmy8514sy.fon
- l336
- rcx
CX 1C20
:2440
- w
Writing 02440 bytes
- q

In your system.ini file, replace fonts.fon=8514sys.fon with fonts.fon=my8514sy.fon.



Zip code bar code fonts 92-11-11
Word Office Productivity Pack (wopr-20a.zip and wopr-20b.zip on ftp.cica.indiana.edu and its mirror 
sites) will automatically print bar codes on envelopes.    The package does require Word for Windows 
2.0, though.



Applications
DayBook: running on Windows 3.1
Norton Desktop: Wider listbox for Scheduler 92-11-15
Norton Desktop: Using smaller fonts for lists 92-11-15
Word for Windows: custom toolbar icons 92-11-15
Word for Windows: drop caps (large 1st characters of paragraphs) 92-09-13
Word for Windows: fonts larger than 127 points 92-11-11
Word for Windows: getting rid of the list of last files edited
Word for Windows: inserting today's date 92-11-11
Word for Windows: linking in subdocuments 92-11-02
Word for Windows: overlining words 92-09-14
Word for Windows: setting the find file default directory 92-09-19
Word for Windows: using a watermark 92-11-15



DayBook: running on Windows 3.1
The Windows 3.0 doesn't work well after upgrading to Windows 3.1.    However, you can get it working
and even keep your old datafiles using the following steps:

· Install ToolBook again (run tbksetup) after renaming your old daybook.tbk file.
· Start DayBook with the empty daybook.tbk.
· Open the old daybook file (from windows version 3.0)
· Save it as daybook.tal.
· Exit ToolBook.
· Rename daybook.tal to daybook.tbk.                                                                          
· Now you can use the old information again under Windows 3.1



Norton Desktop: Wider listbox for Scheduler 92-11-15
You can change the Scheduler's listbox width by using a resource editor (such as Resource 
Workshop, included with Borland's latest Windows language products) to resize the list box, move the
headings and move the buttons.

If you don't have any programming tools, you are basically out of luck.



Norton Desktop: Using smaller fonts for lists 92-11-15
Most of the listboxes in NDW use the font size selected in the menus; make sure you select the 
correct size.



Word for Windows: custom toolbar icons 92-11-15
To change the icons in the Word for Windows 2.0 toolbar, add the line

LoadToolbarBitmaps=1
in the [WinWord2.0] section of your win.ini file.    When Word starts up, it will look for and load four 
bitmaps called V1TBAR.BMP, V2TBAR.BMP, V3TBAR.BMP and V4TBAR.BMP.    Each bitmap holds 
26 "icons" which of 18 pixels wide and 16 pixels high.

This technique will not work if you are using the 8514 large fonts.    It is also undocumented and thus 
unsupported by Microsoft.



Word for Windows: drop caps (large 1st characters of paragraphs) 92-09-13
Creating a drop cap is really quite easy in Word, once you know what you are looking for. 

Create the paragraph, select the first character, change it to the font and size you want it to be, and 
then select Insert » Frame to create a frame.    The frame will automatically size to the character and 
align with the top of the paragraph.    That's all there is to it!



Word for Windows: fonts larger than 127 points 92-11-11
Since Word for Windows will not allow selection of a pointsize beyond 127, for very large pointsizes 
the best thing to do is enter the text in WordArt, and then scale the WordArt object to desired size in 
the Word document.



Word for Windows: getting rid of the list of last files edited
To empty the list of last files edited before someone else uses your machine, simply remove the file 
winword.ini from your Word for Windows directory.    You may wish to put this in your 
autoexec.bat file.



Word for Windows: inserting today's date 92-11-11
Using Word's built-in Insert » Date and Time... command will insert a date, but will update it every 
time you open the document.    There are several ways to insert today's date and forcing it not to be 
updated:

After using Insert » Date and Time..., select the date and hit Ctrl+F9 to lock the field.    This will
cause it not to be updated until you unlock it.

After using Insert » Date and Time..., select the date and hit Ctrl+F9 to unlink the field.    This 
replaces the field with its contents; you will not be able to update the field again.

Use Insert » Field... and inset a CREATEDATE field.    This will insert the date the document 
was created, however, and not necessarily today's date.



Word for Windows: linking in subdocuments 92-11-02
Word for Windows' Link Document, Include document and Insert Document commands all include the
entire text of the subdocument in the main document.    If you want to "link" in a document for indexing
or a table of contents but not bloat up the main document with all the actual text, use the RD (Refer 
Document) field.    It won't print or edit the subdocument from the main document, but it does work for 
indexing and tables of contents.



Word for Windows: overlining words 92-09-14
To overline a phrase in Word for Windows, insert a \eq field and use the \x\to option to draw just 
the top of the box around the "equation".    So, for example, to overline "Bar", you might enter

The Foo {\eq \x\to(Bar)} and Grille



Word for Windows: setting the find file default directory 92-09-19
Select Tools » Macro and edit FileFind; it will look something like this:

Sub MAIN
ToolsMacro "FileFind", .Run
End Sub

Change it to look like this:

Sub MAIN
On Error Goto STOPHERE  'Needed if user chooses Close 

Dim myfilefind As FileFind 'Define a dialog (same as FileFind dialog)
GetCurValues myfilefind 'Get any values you may have already set

myfilefind.SearchPath = "c:\windows"      'Use this type of line to set all the
myfilefind.Name = "*.*"                                'defaults things your little heart desires

Dialog myfilefind 'Display the dialog box on the screen

STOPHERE: 'Just a label
End Sub

For information on the various things you can tag on to "myfilefind", such as .SearchPath, .Name, 
etc..., check the on-line help under Word Basic Commands -- FileFind.

Thanks to Paul Brown for the solution!



Word for Windows: using a watermark 92-11-15
To place a watermark (usually a large a light gray text at an angle behind your normal text), you will 
need a PostScript printer.    If you have such a printer, you can either use the Watermark macro from 
newmacro.doc.    Alternately, insert a Print field into the header, containing the following PostScript 
code:

\p page "/Fn {findfont exch scalefont setfont} bind def
0.98 setgray
50 600 moveto
-45 rotate
180 /Helvetica Fn
(DRAFT) show"

This puts the word "DRAFT" at a 45 degree angle across the page in very light grey large letters.



Gang screens
This section describes the ways to display the secret or gang screens, showing the authors of various
packages, often with associated fireworks and/or other animation.

Windows 3.0
Windows 3.1
Ami Pro 2.0
Excel 3.0
Norton Desktop for Windows 2.0
Procomm Plus for Windows 1.0
Word for Windows 1.x
Word for Windows 2.0



Windows 3.0
· Make Program Manager active
· While holding down F3, press  W I N 3.    Release F3.



Windows 3.1
· Make Program Manager or any desk accessory active
· Select Help » About, hold down Shift+Ctrl+Alt, double-click on icon, press OK
· Repeat
· Repeat to get the first "gang screen"
· Repeat to get the second "gang screen"
· Repeat to get the third "gang screen"



Ami Pro 2.0
· Select Help » About
· Hold down Shift, Ctrl and Alt
· Press F7.    Type  S P A M.    
· Enter the last and third last digits from the Available memory display.
· Release Shift, Ctrl and Alt

Thanks to Avinoam Shmueli.



Excel 3.0
· Select Formula » Goto, enter iv16384.
· Use the scroll bars to make this the only cell visible.
· Reduce the row and column widths to zero.    
· Double-click on the single remaining button at the top left corner.

Thanks to Aaron Wallace.



Norton Desktop for Windows 2.0
· Select Help » About
· Hold down N, D and W
· Double-click on the icon.

Thanks to Mark Scase.



Procomm Plus for Windows 1.0
· Select Help » About
· Press Credits



Word for Windows 1.x
· Turn CapsLock on
· Select Format » Define » Styles » Options
· Select Normal for Based On
· Press OK
· Press Cancel
· Select Help » About
· Move cursor to inside dialog box, then hold down O, P, U and S at the same time.    

Thanks to Todd Lutz.



Word for Windows 2.0
· Select Tools » Macro
· Enter spiff, press Edit
· Delete all lines except for the middle blank line
· Select File » Close, press Yes
· Select Help » About, double-click on icon



Applications
Windows 2.x Applications
Troubleshooting 92-11-09
Available Windows 3.x applications 92-11-11



Windows 2.x Applications
If you run in real mode of Windows 3.0, the old applications behave just like in 2.x, but have 
somewhat less memory available to them.    If the applications are "well-behaved", they may also run 
in standard and 386 enhanced modes, but Windows will first warn you with a "nag" message that the 
application wasn't written for Windows 3.x.    If you run a ill-behaned application in standard or 386 
enhanced mode, the application will likely crash.

If you have a 2.x application that runs well in all modes, you can mark it Windows 3.0-compatible 
using either the mark3.exe or the nonag.exe utility.    Both are available from cica.

Basically, Windows 3.1 will no longer run Windows 2.0 applications.



Troubleshooting
AllType: converted TrueType fonts not in same family 92-09-15
Ami Pro: table of contents
Ami Pro 2.0: divide by zero error
Ami Pro 3.0: overlapped screen text
Ami Pro 3.0: slow printing
FrameMaker: scrambled dot-matrix output 92-09-14
KA9Q: dropped packets 92-09-14
Norton Desktop for Windows: can't format in the background
Mathematica 2.0 for Windows: problems with Windows 3.1, other problems
PageMaker 4.0: font selection box won't scroll 92-09-21
PageMaker 4.0: text color changes to almost invisible 92-09-26
PageMaker 4.0: WordPerfect and Word for Windows import
Pathway Access 1.x: terminal font
PC Tools 7.1: restore problems
Procomm Plus for Windows: Zmodem transfer startup
Quicken for Windows: conflicts with communications software
Ventura Publisher 3.0: divide by zero errors 92-09-19
WinFax Pro 2.0 92-09-19
Word for Windows: accessing fonts
Word for Windows 2.0: can't install additional components
Word for Windows 2.0: equation editor fonts
Word for Windows 2.0: equations have too much white space 92-09-27
Word for Windows 2.0: file too big to save 92-11-09
Word for Windows 2.0: headers and graphics
Word for Windows 2.0b: printing from Print Preview
WordPerfect for Windows 1.0: floppy access
WordPerfect for Windows 1.0: button bar won't display
WordPerfect for Windows 1.0: crashes with 256-color display driver 92-09-21
WordPerfect for Windows 1.0: mixing landscape and portrait pages
WordPerfect for Windows 1.0: printing with TrueType



AllType: converted TrueType fonts not in same family 92-09-15
When AllType converts a, say, PostScript Type 1 font into TrueType, it does not maintain the 
connection between the Regular, Bold, Italic and Bold Italic fonts in the same family.    Thus, if you 
have a font called Franciano and select bold in your word processor, you will get a synthesized bold 
version, not Franciano Bold.

To correct this, you might try a shareware utility called renamett, which allows you to specify the 
family of the font.



Ami Pro: table of contents
If your page numbers in the Table of Contents are all 1, you have likely generated the TOC twice 
without making any changes.    To work around this bug, make a trivial change to your document, and 
regenerate the table of contents.



Ami Pro 2.0: divide by zero error
If Ami Pro crashes with a Divide by Zero error in Windows 3.1, check the version number in the 
About... box.    If your version is earlier than 306, contact Lotus for a free upgrade to 306, which is fully
compatible with Windows 3.1. 



Ami Pro 3.0: overlapped screen text
On some configurations, selecting a block of text and then starting to type over it will not erase the 
existing text first before placing the new characters on it, resulting in a corrupted screen display.

As a workaround, you may choose to either use draft mode or to turn off full justification.

A fix diskette for this problem is available by calling Lotus technical support.



Ami Pro 3.0: slow printing
If you are suffering from slow printing with Ami Pro 3.0, try the following steps to improve the printing 
speed: 

· Disable Print manager in the Windows Control Panel
· Disable Background Printing in Ami Pro's Tools: User Setup: Options.



FrameMaker: scrambled dot-matrix output 92-09-14
FrameMaker will produce correct output only if the output device has square pixels; that is, your 
printer must have the same horizontal and vertical resolution.    A 144 horizontal by 192 vertical 
resolution will produce scrambled output.    Unfortunately, the only choices are to use your printer in a 
"square-pixel" resolution, or to switch to a printer with such a resolution (most laser printers have 
square pixels). 



KA9Q: dropped packets 92-09-14
In order to run properly within Windows 3.x and not drop packets, you need to do two things: 

· Start KA9Q with the -w option
· After starting KA9Q, start winpkt



Norton Desktop for Windows: can't format in the background
While Windows is limited by DOS in some of its multitasking capabilities (such as disk i/o), it can 
format floppies in the background (File Manager does it!).    NDW arbitrarily refuses to let you do 
anything else while formatting    it's a design feature!

Personally, I only buy preformatted diskettes!



Mathematica 2.0 for Windows: problems with Windows 3.1, other problems
Mathematica 2.0 does not work well with Windows 3.1.    It also has a host of other problems which 
exhibit themselves even under Windows 3.0.

The cure is to upgrade to Mathematica 2.1; the upgrade cost is US$ 50.



PageMaker 4.0: font selection box won't scroll 92-09-21
This is a known problem.    The workaround to use, if you have more fonts than will fit in the selection 
box, is to press Ctrl+T to change the text attributes (and thus the font).



PageMaker 4.0: text color changes to almost invisible 92-09-26
this problems stems from an incompatability between PageMaker and Windows 3.1 video drivers.    
Although no fix is currently available, you can work around the problem by switching between 
PageMaker and the other "color intensive" application (which changes the colors) with Alt+Tab 
instead of minimizing one and then restoring PageMaker.    If the colors have already been munged, 
start up command.com full-screen, exit it, and then maximize PageMaker again to restore the colors.



PageMaker 4.0: WordPerfect and Word for Windows import
As shipped, PageMaker 4.0's import filters do not support WordPerfect 5.1 for Windows (although 
WordPerfect 5.1 for DOS is OK), or Word for Windows 2.0.    If you cannot locate the import filters at 
an ftp site or CompuServe, contact Aldus for free updates.



Pathway Access 1.x: terminal font
If in your 10x16 terminal font the uppercase 'K' and lowercase 'k' appear identical, contact 
Wollongong for an update to a corrected terminal font.



PC Tools 7.1: restore problems
PC Tools 7.1 does not check backups for data integrity while restoring, thus possibly restoring corrupt 
data due to media errors on the disks.    This is not a bug, but a deficiency in PC Tools, and is unlikely 
to be corrected prior to the release of the next version.

PC Tools also sometimes corrupts the last disk while doing a restore.    Once the last disk has been 
read, you should immediately remove it from the drive.



Procomm Plus for Windows: Zmodem transfer startup
If you initiate a Zmodem transfer from Procomm, the other end of the link may or may not 
automatically detect the start of a transfer, depending on the software at that end; it's not dependent 
on Procomm.    Specifically, the sz/rz software on Unix does not start Zmodem transfers automatically.



Quicken for Windows: conflicts with communications software
If Quicken produces a General Protection Fault on startup when you have a communications package
already running, it is likely trying to get at the serial port (which is already in use).

To correct this problem, select Edit » Preferences » Electronic Payment, and disable all the bank 
accounts.    Click OK, and exit Quicken.    If this does not cure the problem, select Edit » Preferences 
» Modem Settings, and set Quicken to use a different serial port than your communications package.

If you actually want to use the electronic payment feature of Quicken, you will not be able to run it at 
the same time as a communications package.



Ventura Publisher 3.0: divide by zero errors 92-09-19
Ventura Publisher 3.0 may get frequent divide by zero errors when used with Windows 3.1.    These 
appear to be related to non-Microsoft TrueType fonts, which Ventura is unable to use reliably (the 
TrueType fonts from CorelDraw also cause problems).    You may wish to remove either all or selected
non-Microsoft TrueType fonts from your system to prevent the Ventura errors.

Ventura Publisher will also refuse to run with a display driver which uses more than 256 colors.



WinFax Pro 2.0 92-09-19
If you are having difficulty sending faxes with WinFax Pro, check the date of the file mod.exe; if it is 1-
16-92 16:51, 62,976 bytes , you should get a replacement from Delrina (call cuatomer support at 
(800) 268-6082).



Word for Windows: accessing fonts
Word for Windows shows in its font menu the fonts currently available for the selected output device, 
not the display device.    You can still use, say, vector fonts that you installed, by typing the name of 
the font in the edit box.    Windows will draw vector fonts on the output device without problems    you 
may or may not like the results. Screen fonts are also useable for printing on dot-matrix printers.    
These problems do not occur with TrueType fonts in Windows 3.1, as they are available both on the 
printer and on the display.

After you have installed new fonts (TrueType, ATM or any others), you need to force Word for 
Windows to refresh its output device font list.    The easiest way to do this is to do File » Printer » 
Setup, click Setup, then click OK, and finally OK again.



Word for Windows 2.0: can't install additional components
If Word for Windows won't install additional components (such as the thesaurus or spellchecker) 
because it claims Word is not yet installed, check your win.ini file, and make sure that under 
[Microsoft Word 2.0], you have the line ProgramDir=C:\WINWORD (or whatever your Word for 
Windows directory name is).



Word for Windows 2.0: equation editor fonts
If Word for Windows complains about missing MT Extra or MT Fences fonts, but they are installed in 
the control panel, you will need to reinstall them (this most commonly happens if you upgrade to 
Windows 3.1 after installing Word for Windows).    This is easiest done by using Word's Setup 
program to remove Equation Editor, removing the MT Extra and MT Fences fonts with Control Panel, 
and then reinstalling the Equation Editor.

This bug most frequently occurs if your printer port is set to FILE: when installing Word for Windows.



Word for Windows 2.0: equations have too much white space 92-09-27
If you're using superscipts or subscripts in your equation, there will likely be too much whitespace 
above the equation.    If you check the character format, the equation will be subscripted by a large 
number, such as 40 points.    You can manually reset the subscript amount; however, the subscript will
be set again when you print, if you have Update Fields checked under File » Print » Options.

You can also use the following macro (written by Harvey Cohen, hsc@honet6.attcom) to correct the 
spacing of all the equations in your document:

Sub MAIN
StartOfDocument
ViewFieldCodes 1
EditFindClearFormatting
EditReplaceChar .Font = "", .Points = "", .Bold = - 1, .Italic = - 1,

.Strikeout = - 1, .Hidden = - 1, .SmallCaps = - 1, 

.AllCaps = - 1, .Underline = - 1, .Color = - 1,

.Position = "0pt", .Spacing = ""
EditReplace .Find = "^19EMBED EQUATION ", .Replace = "^m", 

.WholeWord = 1, .MatchCase = 1, .Format = 1, .ReplaceAll = 1
ViewFieldCodes 0
End Sub

This problem is corrected in Word for Windows 2.0b.



Word for Windows 2.0: file too big to save 92-11-09
This appears to be an oocasional problem with versions 2.0 and 2.0a, although most users never 
experience it, even when working with large documents.

Some of the workarounds that have been reported to work for some users are:
Select the entire document and paste it into another document
Select a non-PostScript printer and save
Save the document as RTF
Turn off Fast Save



Word for Windows 2.0: headers and graphics
If you have problems with disappearing headers or footers, or with displayable graphics not printing, 
call Microsoft customer support for an upgrade to version 2.0a.



Word for Windows 2.0b: printing from Print Preview
If you install the macros in pss.doc (included with Word 2.0b), you will no longer be able to print from 
the Print Preview window.    The following are two workarounds provided by Ron Apland 
<apland@mala.bc.ca>:

Select Tools » Macro » Edit FilePrint, erase the existing macro and insert the following:
   Sub MAIN
       Dim dlg As FilePrint
       GetCurValues dlg
       Dialog dlg
       Super FilePrint dlg
   EndSub

                    This will get you back to the original print macro.
                                                                                                                                                                

Select Tools » Macro » Edit FilePrint, and insert the following immediately after Sub MAIN:
     chkpv = FilePrintPreview()
     If chkpv <> 0 Then
       Dim dlg As FilePrint
       GetCurValues dlg
       Dialog dlg
       Super FilePrint dlg
       Goto Bye
     EndIf

                      This will run the original print macro if and only if you are using Print Preview.



WordPerfect for Windows 1.0: floppy access
If    WordPerfect for Windows refuses to access your A: drive, add the line

HighFloppyReads=0
in the [386Enhanced] section of your system.ini file.



WordPerfect for Windows 1.0: button bar won't display
If    WordPerfect for Windows won't display your button bar despite selecting it from the menus, make 
sure it is looking in the right directory.    Select Macros » Keyboards » Button Bars, and make sure 
the directory is set to your macros subdirectory.



WordPerfect for Windows 1.0: crashes with 256-color display driver 92-09-21
WordPerfect for Windows may crash (with a UAE or GPF) when used with a display driver capable of 
using more than 16 colors, or when used with ATI's Crystal Fonts driver.    To correct this problem, 
contact WordPerfect technical support, and request a copy of the interim release.    Once you have 
the interim release, start it with the /fl option to avoid crashes.



WordPerfect for Windows 1.0: mixing landscape and portrait pages
WordPerfect for Windows will not allow you to mix landscape and portrait pages in a single document 
if you are using a Windows printer driver.    This is a known limitation and not classified as a bug.



WordPerfect for Windows 1.0: printing with TrueType
WordPerfect for Windows will correctly print documents containing TrueType fonts only if one of the 
following is true:

· You are using a Windows-based printer driver, not a WordPerfect one.
· You are using a TrueImage printer, with a WordPerfect driver which supports TrueType.



Available Windows 3.x applications
The following sections list some of the applications available for Windows 3.x    While it does not 
attempt to be a comprehensive list, it does attempt to list the most popular commercial software 
packages and some selected shareware.    This is not intended to be a review, but, rather, an 
overview of available titles.    You should perform your own evaluation to determine the software best 
suited to your needs.

All prices listed are U.S. list prices at time of compilation, and cannot guaranteed to be correct.

If the application is available on another platform at better or at least substantially the same level of 
development, a code indicating that is shown in the header.    Windows NT portability is not shown, as
Windows NT is not yet available, and while most major vendors have announced NT versions of their 
software, very little concrete information is available.:

[Mac] Macintosh
[Sun] Sun OpenLook
[Motif] Motif
[PM] OS/2 Presentation Manager

See the Windows Programming Tools FAQ for a description of available development tools.
Business Applications 92-10-03
Graphics Applications 92-11-11
Communications 92-10-03
Utilities 92-11-11
Multimedia and Entertainment 92-10-05



Business Applications
Databases, non-programmable
Databases, programmable 92-09-21
Desktop publishing
Financial Management
Groupware 92-09-20
Integrated sofware 92-10-03
Personal Information Management 92-09-20
Project management
Spreadsheets
Word processing



Databases, non-programmable

· Superbase 2
SPC.    A non-programmable version of Superbase 4.    List $ 345.



Databases, programmable 92-09-21

· Claris FilePro    [Mac]
Claris.    A Windows port of the Macintosh-based FilePro,    List $ ?.

· DB Vista III
Raima.    A network (not relational) database.

· dBase for Windows
Borland.    Announced, but not shipping.    Feature set not well known.    List $ ?.

· dBFast for Windows 
Computer Associates.    xBase compatible.    List $ 550.

· FoxPro 2.5 for Windows    [Mac]
Microsoft.    Announced, but not shipping.    Implements a superset of dBase IV commands.    List $ ?.

· Progress    [Sun] [Motif]
Progress Software.    A Windows version of Progress 4GL, which runs on DOS VMS, and dozens of 
different Unix versions.    Version 6.2 provides limited access to Windows interface; 7.0 will access a 
fuller feature set.    List $ ?.    Runtime licences.

· Superbase 4
SPC.    A midrange graphical database package.    List $ 695.

See also the list of database libraries in the Windows Programmer's FAQ.



Desktop publishing

· ArcheType Designer
Archetype.    A full-featured package for relatively short commercial material such as ads and 
brochures.    List $ 795.

· Express Page
Carberry Technology.    An front end for PageMaker for doing quick layout designs and draft versions.  
List $ 195.

· FrameMaker 3.0 for Windows    [Sun] [Motif] [Mac]
Frame.    A high-end integrated word processing and desktop publishing package.    List $ 795.

· Microsoft Publisher
Microsoft.    An easy-to-use basic package.    List $ 199.

· PageMaker for Windows    [Mac]
Aldus.    A full-featured high-end package.    List $ 795.

· PagePlus for Windows
Serif.    A low-price packaged with some high-end features.    List $ 149.

· Ventura Publisher, Windows Edition
Xerox.    A full-featured high-end package, ported from the original GEM-based version.    List $ 795.



Financial Management

· Microsoft Money 
Microsoft.    A personal financial management package, fairly comparable to Quicken.    List $ 69.

· Quicken for Windows    [Mac]
Intuit.    Compatible with the ubiquitous Quicken for DOS.    List $ ?.



Groupware 92-09-20

· 1Team
1Soft.    A networked PIM aimed at scheduling and to-do lists, with a very similar user interface to 
Active Life.    Evaluation copies are available from cica and other sites.    List $ 295 (2-user), $ 99 
(additional users).

· Network Scheduler 3.0
PowerCore.    Network-based group scheduler.    List $ 395 (5-user), $ 1,195 (25-user).

· Lotus Notes
Lotus.    Integrated information sharing using networks.    List $ 62,500 (200-user).

· NOTE-IT
Chord. A network-based system of using Post-It notes.    List $ 249 (unlimited).

· PackRat for Networks
Polaris.    A version of PackRat for networks, with group scheduling, and document and information 
sharing.    List $ 695 (3 users).

· Pinboard
Raindrop Software.    Post-It notes for Windows.    List $ 399 (unlimited).



Integrated sofware 92-10-03

· CA-Simply Business
Computer Associates.    Accounting, word processing, 3-D spreadsheet, project scheduling and 
graphics.    List $ 567.

· Eight-In-One for Windows
Spinnaker.    Word processor, spreadsheet, database, communications and graphics.    List $ 59.

· PFS: WindowWorks
Spinnaker.    Word processor, spreadsheet, database, communications and graphics.    List $ 149.

· Microsoft Works for Windows    [Mac]
Microsoft.    Word processor, spreadsheet, database, communications and graphics.    List $ 199.

· Microsoft Works for Windows, Multimedia Edition
Microsoft.    Word processor, spreadsheet, database, communications and graphics.    Multimedia 
tutorial; available on CD-ROM only.    List $ 199.

Two other available packages, Microsoft Office and Lotus SmartSuite, consist of bundled individual 
applications from the respective vendors, and are not integrated systems in the traditional sense.



Personal Information Management 92-09-20

· Active Life
1Soft.    A PIM aimed at scheduling and to-do lists.    Evaluation copies are available from cica and 
other sites.    List $ 149.

· Ascend
NewQuest technologies.    A high-end PIM with to-do lists, dialer, scheduling and information 
management.    List $ 299.

· Commence
Jensen-Jones.    A high-end forms-based personal information manager, from the developers of IBM 
Current.    Has a very flexible network-type database, but requires substantial initial effort to set up.    
Also includes advanced macros and macro trigger events. List $ 295 (Upgrade from Current $ 99).

· Current
IBM.    A high-end forms-based personal information manager.    Has a very flexible network-type 
database, but requires substantial initial effort to set up.    IBM has announced that it plans to 
discontinue sales (but not support) of Current.    List $ 395.

· Desktop Set
Okna.    Calendar, rolodex, dialer, to-do list, etc.    List $ 89.

· Epoch
Raindrop Software.    Scheduler and to-do list.    List $ 129.

· PackRat
Polaris.    A high-end PIM with agenda, phonebook, to-do list, financial management, project tracking, 
etc.    Network version available.    List $ 395.

· Pinboard
Raindrop Software.    Post-It notes for Windows.    List $ 129.

· ShoeBox for Windows
R+R Associates.    A high-end PIM with group scheduling, project and expense tracking, calendar and 
to-do lists.    List $ 395.

· WinPost
Eastern Mountain Software.    An excellent shareware package for managing Post-It notes on the 
Windows desktop.    Registration $ 30.

· YourWay
Prisma Software.    Time and contact management.    List $ 199.



Project management

· CA-SuperProject for Windows 
Computer Associates.    A midrange rewrite of the venerable DOS-based package.    List $ 895.

· CADENCE ProjectMaster
CADENCE.    A low-end with task/responsibility linking.    List $ 295.

· Milestones, Etc.
KIDASA.    A low-end package oriented toward graphical scheduling.    List $ 189.

· OnTarget
Symantec.    A low-end package.    List $ ?.

· Project Director
AdRem.    List $ ?.

· Project for Windows    [Mac]
Microsoft.    A midrange package with excellent user interfce but less emphasis on advanced 
scheduling.    $ 695.

· Scitor Project Scheduler 
Scitor.    List $ ?.



Spreadsheets

· CA-Compete! 2.0
Computer Associates.    A multidimensional spreadsheet, aimed at financial analysis,    with an Excel 
3.0-based user interface.    List $ 995.

· Excel for Windows 4.0    [Mac]
Microsoft.    A full-featured high-send spreadsheet.    List $ 495.

· WingZ
Informix.    A midrange spreadsheet.    List $ 499.

· Lotus 1-2-3 for Windows 1.0 
Lotus.    A high-end spreadsheet with full 1-2-3 Classic compatability.    Suffers from poor performance 
compared to Excel.    List $ 495.

· Quattro Pro for Windows
Borland.    A high-end spreadsheet with a notebook 3D idiom.    A strong contender.    Not yet shipping. 
List $ 495.

· Thinx
Bell Atlantic.    Not really a spreadsheet, but an application allowing you to build data and links 
between objects.    List $ 495.



Word processing

· Lotus Write 1.0
Lotus.    A low-end easy-to-use package, previously sold as Samna Ami and then Lotus Ami. List $ ?.

· Ami Pro 3.0
Lotus.    A full-featured high-end package with desktop publishing features.    Ami Pro 3.0 matches 
Word for Windows 2.0 in power and features.    List $ 495.

· FrameMaker 3.0 for Windows    [Mac] [Sun]
Frame.    A high-end integrated word processing and desktop publishing package.    List $ 795.

· JustWrite
Symantec.    A basic easy-to-use package.    List $ 199.

· Legacy
NBI.    A frame-oriented high-end package.    Does not match Ami Pro or Word for Windows in features
or performance.    List $ 495.

· Professional Write for Windows
SPC.    A mid-range package with an E-mail interface.    List $ 249.

· Word for Windows 2.0b
Microsoft.    A full-featured high-end package aimed more at writing than at desktop publishing.    
Includes WordPerfect command emulation.    List $ 495.

· WordPerfect for Windows    [Mac] [Sun]
WordPerfect.    A full-featured high-end package.    Includes all WordPerfect printer drivers and a 
choice of CUA or WordPerfect user interface.    Cannot match the speed or features of Ami Pro or 
Word for Windows.    List $ 495.

· WordStar for Windows 1.5
WordStar.    A near-high-end package originally based on Ami, with strong graphics and frame 
manipulation.    No macros.    List $ 495 ($ 119 until the end of 1992).



Graphics Applications
CAD 92-11-09
Databases, image
Drawing and Illustration 92-09-27
Graphics conversion 92-10-04
Image viewers
Painting and image editing 92-10-06
Presentation graphics 92-11-11



CAD 92-11-09

· AutoCAD Rel.12 Windows Extension 
Autodesk.    A mid-to-high-end CAD system oriented toward civil and architectural applications, with 
3D capabilties.    A front end for AutoCAD Rel. 12 (required).    Fully integrated Windows version to be 
available for NT.    List $ ?.

· CADvance 5 for Windows 3.1
IsaCAD.    A mid-to-high-end package with full AutoCAD file compatability and excellent Windows 
integration.    List $ 1,995 (competitive upgrade $ 395).

· Drafix Windows CAD
Foresight Resources.    A midrange 2-D CAD package.    List $ 595.

· MicroStation 4.03 Nexus
Intergraph.    A mid-to-high end CAD system with a Motif interface and minimal Windows features, but 
including DDE and OLE.    List $ ?.

· Smart Draw for Windows
The Other Operation.    A low-cost low-end 2-D CAD package.    List $ 99.

· Ultimate CAD Windows
Automated Methods.    A midrange 2-D CAD package, with DDE.    List $ 695.



Databases, image

· MultimediaBase
Harley.    List $ ?.

· MediaOrganizer
Lenel.    List $ ?.

· ProFile for Windows
IEV.    List $ 295.

· ShoeBox for Windows
Kodak.    Announced, due to ship 4Q92.    List $ 295.



Drawing and Illustration 92-09-27

· Arts & Letters Graphics Editor
Computer Support.    A fairly easy-to-use high-end package.    List $ 695.

· Arts & Letters Apprentice
Computer Support.    A stripped-down version of A&L.    List $ 125.

· Chartist
Novagraph.    A diagramming and flowcharting package.    Registration $ ?.

· CorelDRAW!
Corel.    The market leader in high-end drawing and illustration software, with extensive set of 
graphics and image manipulation tools.    Available on CD-ROM.    List $ 595.

· Freehand
Aldus.    A high-end drawing and illustration package.    List $ 595.

· Graphics Works
Micrografx.    A semi-integrated package containing Windows Draw, PhotoMagic, OrgChart and clip art
and photo collections.    List $ 199 (not yet shipping).

· Harvard Draw for Windows 
SPC.    A high-end drawing package.    List $ 595.

· Micrografx Designer 
Micrografx.    A high-end package oriented towards technical illustration.    List $ 695.

· Microsoft Draw 
Microsoft.    A very basic package with OLE.    Included with Word for Windows.

· Professional Draw
Gold Disk.    A powerful high-end drawing package.    List $ 595.

· Smart Draw for Windows
The Other Operation.    A 2-D CAD package for Windows.    List $ 99.

· VentanaDraw 
Micrografx.    A low-end drawing package.    List $ 149.

· Windows Draw 
Micrografx.    A low-end package with many high-end features, OLE and TrueType fonts.    List $ 149.

· XVT Draw    [Mac] [Sun] [Motif] [PM]
XVT.    A shareware package with very basic features.    Registration $ ?.



Graphics conversion 92-10-04

· DoDOT
Halcyon.    Extensive file conversions and full-color editing.    List $ 189..

· Graphics Workshop for Windows
Alchemy Mindworks.    An image conversion and manipulation utility with an extensive feature set.    
Registration $ 40.

· HiJaak for Windows
Inset.    A screen capture (for Windows and DOS) and conversion utility.    List $ 199.

· Image-In Paint and Scan
Image-In.    A grayscale painting and image processing package.    List $ 99.

· PaintShop Pro
JASC.    A shareware package with extensive capture, file conversion and color manipulation features.
Registration $ 49.



Image viewers

· ColorView, ColorView/386
Millenium Technologies.    A shareware package with both GIF and JPEG support.    Version 0.97 is 
quite fast but somewhat buggy.    Registration $ 30.

· GhostScript for Windows
The GNU Project.    EPS (Encapsulated PostScript) viewer.    Free.

· JView, JView/386
David Holliday.    A fairly fast JPEG-only viewer.    Free.

· PaintShop Pro
JASC.    A shareware package with 24-bit color and good dithering but no JPEG support.    
Registration $ 49.

· WinGIF
A GIF viewer, but with no JPEG support.    Registration $ ?.

· WinJPEG
A Windows JPEG viewer.    Registration $ ?.



Painting and image editing 92-10-06

· CA-Cricket Image
Computer Associates.    A 24-bit image processing and conversion package.    List $ 92 until 93-01-31,
regularly $ 295.

· CA-Cricket Paint
Computer Associates.    A 24-bit painting and image editing package.    List $ 92 until 93-01-31, 
regularly $ 595.

· CorelDRAW!
Corel.    The market leader in high-end drawing and illustration software, with extensive set of 
graphics and image manipulation tools.    Available on CD-ROM.    List $ 595.

· DoDOT
Halcyon.    Extensive file conversions and full-color editing.    List $ 189..

· Fractal Design Painter
Fractal Design.    Fully-featured package oriented towards original image creation.    List $ 399.

· Graphics Works
Micrografx.    A semi-integrated package containing Windows Draw, PhotoMagic, OrgChart and clip art
and photo collections.    List $ 199 (not yet shipping).

· Image-In Color
Image-In.    A 24-bit image processing and retouching package.    List $ 495.

· Image-In Paint and Scan
Image-In.    A grayscale painting and image processing package.    List $ 99.

· Image Pals
Image-In.    A 24-bit image processing    and management package, with JPEG support.    List $ 249.

· PhotoMagic
Micrografx.    A low-end 24-bit color image manipulation package.    List $ 149 (not yet shipping).

· Picture Publisher
Micrografx.    A powerful image manipulation package.    List $ 795.

· Publishers' Paintbrush
Zsoft.    Extensive 24-bit painting and image manipulation capabilities.    List $ 495.



Presentation graphics 92-11-11

· Arts & Letters Graphic Composer 
Computer Support Corp.    A full-featured presentation package with 24-bit support.    List $ 395.

· DeltaGraphics Professional
?.    A scientific graphics package.    List $ ?.

· GNUplot for Windows
?. A command-line driven plotting package, also available on a wide variety of other platforms.    Free.

· Harvard Graphics for Windows 
SPC.    A full-featured Windows-based rewrite of the venerable Harvard Graphics for DOS.    List $ ?.

· Hollywood
Claris.    A high-end presentation package previously marketed by IBM.    List $ 499.    

· Persuasion
Aldus.    A high-end package.    List $ 495.

· Powerpoint    [Mac]
Microsoft.    A full-featured presentation software package.    List $ 495.

· Stanford Graphics for Windows 2.0
3-D Visions.    A presentation software package oriented towards technical users.    With extensive 3D 
graphics and other powerful features, but will make a 486/33 seem slow.    List $ 495.
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Communications

· Crosstalk for Windows
DCA.    VT320, Zmodem and LAN support.    List $ 195.

· Dynacomm
FutureSoft.    VT340 and Zmodem support.    List $ 249.

· EM320 Windows
Diversified Computer Systems.    VT320 emulation, Kermit.    List $ 229.

· KEAterm 420
KEA Systems.    VT420 and SuperKermit over TCP/IP, Pathworks, LAT and Int14.    List $ 245.

· MasterComm
MicroPlot Systems.    VT220, Tek4010, Tek4014, Kermit, XModem support.    Connect through 
modem, DECNET, Novell, 3Com or TCP/IP.    List $ 95.

· MicroCourier
Microcom.    List $ 99.

· MicroPhone II for Windows    [Mac]
Software Ventures.    VT102, Zmodem and Novell support.    List $ 195.

· Procomm Plus for Windows 
Datastorm.    Numerous emulations (including VT320) and protocols (including Zmodem) and an 
advanced (if somewhat non-standard) user interface.    List $ 139.

· Reflection 1 for Windows 
Walker Richer & Quinn.    HP2392A and HP700/92 emulation.    List $ 399.

· Reflection 2 for Windows 
Walker Richer & Quinn.    VT320, Kermit, Xmodem.    List $ 299.

· Teemtalk 320W
Pericom Software.    VT320, HP2392A, DG200 emulation. Kermit, XModem, YModem protocols.    List
$ 195.

· Terminal Plus
FutureSoft.    An advanced version of Windows Terminal, usign a similar user interface, with VT220 
and Zmodem.    List $ 99.

· Unicom
Registration $ ?.

· WinQVT
Registration $ ?.

· WinTerm
Marketfield Software Development.    VT220 over TCP/IP, NetBIOS, LAT, Int14 and others.    List $ 
279.



Facsimile 92-10-03

· Bitfax for Windows
Bit Software.    List $ 79.

· Bitfax/OCR for Windows
Bit Software.    With OCR support for converting faxes into text.    List $ 199.

· Eclipse FAX
Eclipse.    A fax printer driver with thumbnails and good speed.    List $ 119.

· FaxView for Windows
Black Ice Software.    With color fax support.    List $ 179.

· EZ-FAX for Windows 
Calculus.    A fax printer driver.    List $ 499.

· FAXability
Intel.    A fax printer driver.    List $ 119.

· FAXability/OCR
Intel.    A fax printer driver with character recognition.    List $ 249.

· FaxFiler/FaxCapture
Extended Systems.    A network fax management system.    List $ 695 / $ 495.

· FAXit for Windows
SofNet.    A fax printer driver.    List $ 119.

· FaxView for Windows
Black Ice Software.    List $ 129.

· FaxPress 3.0
Castelle.    Network fax service with a Windows client interface.    List $ 3,495.

· LanFax Redirector
Alcom.    Client/server based network fax.    List $ 995.

· ShareFax for Windows
SofNet.    Network fax for any Windows-compatible network.    List $149 (2-user).

· SuperFax for Windows
Pacific Image Communications.    List $ 99.

· WinFax Pro
Delrina.    An advanced version of WinFax (which is supplied with many fax cards); the fax device 
appears to Windows as a printer.    List $ 119.



News readers

· Helldiver
?.    A Windows newsreader based on Waffle.    Registration $ ?.

· WinQVTnet
?. NNTP and SLIP support.    Uses non-standard .newsrc files.    Registration $ ?.

· WinVN
Available at ftp.cica.indiana.edu.    NNTP, SLIP and serial support.    Free.

· WRN
Frank van der Hulst.    NNTP-based newsreader, inspired by xrn.    Free.



X Windows servers

· eXcursion
DEC.    List $ ?.

· FrameworX
IDE.    Includes TCP/IP.    List $ 545.

· HCL-eXceed/W
Hummingbird Communications.    List $ 545.

· PC-Xview for Windows
Spectragraphics.    List $ 445.

· XVision
UniPress Software.    X11R4 support.    List $ 449.
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Backup software

· Central Point Backup
Central Point Software.    List $ ?.

· Norton Desktop for Windows
Symantec.    Program manager, file manager, file recovery, backup.    List $ ?.



Benchmarking utilities 92-04-10

· WinBench
PC Magazine.    Benchmarks performance with typical application usage.    Free.

· WinTach
Texas Instruments.    Benchmarks performance with typical application usage.    Free.



Desktop enhancers

· BigDesk
Registration $ ?.



Font packages 92-11-09

· Agfa Desktop Styles
Agfa.    39 TrueType text and display faces.    List $ 79.

· Agfa Type Jamboree
Agfa.    46 TrueType text and symbol faces.    List $ 99.

· Bitstream TrueType Font Pack 1
Bitstream.    40 TrueType text and display faces.    List $ 79.

· Bitstream TrueType Font Pack 2
Bitstream.    20 TrueType text and display faces.    List $ 39.

· Blue Sky Research Outline Fonts
Y&Y.    The full set of Computer Modern fonts in Type 1 format.    List $ 345.

· Fluent Laser Fonts Library
Casady & Greene.    120 text and display faces.    List $ 179.

· Font Value Pack
QualiType.    150 faces plus 1500 icons.    List $ 99.

· Microsoft TrueType Font Pack
Microsoft.    Lucida Bright, Lucida Sans (? fonts total).    List $ 49.

· Monotype PostScript Value Pack
Monotype.    57 Type 1 text and display faces, including Baskerville, Book Antiqua, Bookman, Calisto, 
Century Gothic and Century Schoolbook.    List $ 89.

· Monotype Presentation FontPack
Monotype.    TrueType versions of    Albertus, Gill Sans Bold Extra Condensed and Swing Bold.    List $
19.

· Monotype TrueType Value Pack
Monotype.    57 TrueType text and display faces, including Baskerville, Book Antiqua, Bookman, 
Calisto, Century Gothic and Century Schoolbook.    List $ 89.

· QualiType Fonts
QualiType.    135 TrueType fonts plus 1500 icons.    List $ 99.

· Optifonts
Castcraft Software.    400 TrueType text and display faces on CD-ROM.    List $ 996.

· SuperType Master Library
QualiType.    150 TrueType faces plus 1500 icons.    List $ 99.

· Top Fonts
EIQ Engineering.    93 TrueType text and display faces.    List $ 199.

· TrueType Font Pack for Windows
Upgrade Systems.    600 TrueType text and display faces.    List $ 129.

· TypeCase
SWFTE International.    131 TrueType text and display faces.    List $ 69.



Individual font packages are also available for varying prices from companies such as Adobe, Bitstream, 
Monotype and Image Club.    Some software, such as CorelDRAW! and Windows Draw also include 
bundled TrueType fonts.



Font Utilities 92-11-09

· Adobe Type Manager 2.0    [Mac]
Adobe.    A scalable font manager; supports Adobe Type 1.    List $ 99.

· AllType
Atech.    Typeface conversion utility; supports Type 1, Type 3, TrueType and Speedo.    Has some 
problems in conversions, and no hinting    List $ 49.

· Bitstream FaceLift
Bitstream.    A scalable font manager; supports Speedo, TrueType and Adobe Type 1.    List $ 99.

· FontMinder
Ares.    Manages fonts by allowing you to activate and deactivate sets of fonts.    List $ 79.

· FontMonger for Windows    [Mac]
Ares.    Typeface editing and conversion utility; supports Type 1, Type 3 and TrueType.    Has 
automatic hinting only.    List $ 129.

· Fontographer for Windows    [Mac]
Typeface editing utility; supports Type 1 and TrueType.    Has automatic hinting only.    List $ ?.

· Incubator for Windows
Type Solutions.    A scalable font manager with special effects.    List $ 149.

· MoreFonts
MicroLogic.    A font manipulation and modification package.    List $ 129.

· Publisher's Powerpak for Windows
Atech.    A scalable font manager.    List $ 79.

· TrueType Font Installer
Kai Kaltenbach.    Preview, print samples and install TrueType fonts.    Registration: a science fiction 
book.



Program launchers: Program Manager type 92-10-04

· Folders
Sloop Software.    Program Manager add-on providing nested folders.    Registration $ 20.

· Plug-In
Plannet Crafters.    A Program Manager extension providing group management, custom group icons, 
QuickRun menu and other enhancements.    Registration $ 20.

· Program Manager Groups
Andreas Furrer.    A Program Manager add-on utility providing hierarchical groups.    Free.

· SloopMan
?.    A program manager replacement with groups-within-groups.    Registration $ ?.



Program launchers: other 92-10-04

· AppBar
Geert van Kempen.    NeXT-style button bar: with trash can.    Free.

· Dashboard
Hewlett-Packard.    Multiple views of application configurations.    List $ 99.

· DropDesk
Scott Bender.    Drag files from the File Manager to the desktop to run them.    Free.

· Dropper
Freely arrangeable buttons on the desktop.    Registration $ ?.

· Norton Desktop for Windows
Symantec.    Program manager, file manager, file recovery, backup.    List $ 179.

· Next
NeXT-style button bar.    Registration $ ?.

· Rooms
Xerox.    organize your applications into multiple desktops ("rooms"), and switch between them while 
running.    List $ ?.

· Route 1
D.A. Karp.    NeXT-style button bar: Visual Basic-based.    Registration $ 14.

· WinDock
Brian Capson.    NeXT-style button bar: clean and easy to use.    Registration $ 15.

· XTree for Windows
XTree.    A Windows version of the venerable DOS-based XTree.    List $ 99.



Task schedulers 92-11-11

· Clocker
Greg Reinacker.    Registration $ ?.

· ClockMan
?.    Registration $ ?.



Task managers

· Task Manager
Guenter Schwaninger.    Registration $ 10.



Miscellaneous 92-10-04

· Cloak
Lorry Back Software.    Hides undesired icons.    Charityware.

· Print Manager
Saber.    Network printer management tool.    List $ 79 (single-user).

· TimeFrame
Places a digital clock on active window's title bar.    Free.

· WizUnzip
An integrated UnZip utility; does not require PKUNZIP.    Registration $ ?.



Multimedia and Entertainment
CD Audio players 92-10-05
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CD Audio players 92-10-05

· CD
John Junod.    A fairly basic Windows audio CD player, with source.    Free.

· CD Player
?.    A basic Windows audio CD player.    Registration $ 10.

· Media Player
Microsoft.    An basic audio CD player.    Included with Windows 3.1.

· WinCD
?.    An audio CD player with shuffle play and programming.    Registration $ 10.



Games

· ChessNet
Masque.    Chess against computer or via modem or network.    List $ 49.

· Kaleidokubes
Artworx.    Color domino cubes (1 or 2 player).    List $ 49.

· New York Times Crossword Puzzle
SWFTE.    200 daily and 50 Sunday crossword puzzles.    List $ 49.

· SimCity for Windows
Maxis.    A sophisticated simulation of a city.    List $ ?.

· Symantec Game Pack for Windows
Symantec.    Six Windows games.    List $ 39.

· Windows Entertainment Pack Vol. 1
Microsoft.    Tetris, Minesweeper, Golf solitaire, Cruel solitaire, and more.    List $ 39.

· Windows Entertainment Pack Vol. 2
Microsoft.    Tut's Tomb solitaire, FreeCell solitaire, Pipe Dream, and more.    List $ 39.

· Windows Entertainment Pack Vol. 3
Microsoft.    Fuji Golf, TriPeaks solitaire, WordZap, SkiFree and more.    List $ 39.

· WinGames
WinSoft.    WinCommand, Chopper Attack, Yacht and more.    List $ 39.

· WinGames II
WinSoft.    MrMind, Lander, Adventure and more.    List $ 49.

Sorry, the shareware and freeware games are just too numerous to mention!    Check your favorite FTP 
site or BBS for availability.



Multimedia and Sound Editors

· Encore
Passport Designs.    Music publishing package for composing and editing music.    List $ 595.

· Sound Brush
MP Technologies.    Sound editor and player.    List $ 250.

· Trax
Passport Designs.    MIDI editor and player.    List $ 595.

· Wave for Windows
Turtle Beach.    Sound editing package.    List $ 149.

· X-oR
Dr. T's Music Software.    MIDI editor and librarian.    List $ 129.



Multimedia Playback

· AmandaStories
Voyager.    Animated stories for children age 3 and up.    List $ ?.

· Composer Quest
Dr. T's Music Software.    Various classical composers, with sound, text and pictures.    List $ 99.

· Multimedia Beethoven
Microsoft.    Experience Beethoven with sound, text and pictures.    List $ ?.

· WinTV
Hauppage.    View NTSC TV in a window.    Includes adapter card.    List $ 495.




